AnsweredAssumed Answered

Creating an enterprise geodatabase in Linux

Question asked by geonetadmin on Mar 21, 2012
Latest reply on Mar 28, 2012 by geonetadmin
Original User: jkuoppam

Hi,

I've struggled with Enterprise Geodatabase installation for ArcGIS 10.1 Prerelease ín Linux, with Postgresql.

Postgresql has been installed according to its installation instructions [1]. The output is in the attachment below.

ArcSDE Application Server and the command line tools have been installed according to their installation instructions [2]. The output is in the attachment below.

Since I don't have network connectivity from my ArcGIS for Desktop to the server yet, I've tried to create the geodatabase using the script shown in http://resourcesbeta.arcgis.com/en/help/main/10.1/index.html#/Scripting_database_and_geodatabase_creation_in_PostgreSQL/002p000000sz000000/ . Outputs to stdout- and stderr are in the attachment below. (Had to zip it since this forums only accepts .txt files up to 12,5 kB)

It seems that an sde schema is created in Postgresql:


[INDENT]postgres=# select * from pg_namespace;
      nspname       | nspowner |               nspacl
--------------------+----------+-------------------------------------
pg_toast           |       10 |
pg_temp_1          |       10 |
pg_toast_temp_1    |       10 |
pg_catalog         |       10 | {postgres=UC/postgres,=U/postgres}
public             |       10 | {postgres=UC/postgres,=UC/postgres}
information_schema |       10 | {postgres=UC/postgres,=U/postgres}
sde                |    16384 | {sde=UC/sde,=U/sde}[/INDENT]


However, starting ArcSDE fails. I've tried with different parameters and left them out even, but the response is always the same:


[INDENT]
[sde@devel ~]$ sdemon -o start -D gis -i 5151
Please enter ArcSDE DBA password:
-------------------------------------------------------
ArcSDE 10.1  for PostgreSQL Build 611 Wed Dec 21 12:41:15  2011
-------------------------------------------------------

FATAL:  database "sde" does not exist
Connection to database 'sde' failed.
init_DB DB_instance_open_as_dba: -162

Could not start ArcSDE -- Check Network, $SDEHOME disk, DBMS settings and dbinit.sde.

[sde@devel ~]$[/INDENT]


What should I try next? What am I missing?

Regards,

--Jarkko

[1] http://wiki.postgresql.org/wiki/YUM_Installation
[2] http://resourcesbeta.arcgis.com/en/help/install-guides/arcsde-application-server-postgresql/10.1/index.html

Outcomes