AnsweredAssumed Answered

Scale-triggered display problem with mosaicked elevation raster

Question asked by ncurri on Jun 21, 2014
Latest reply on Jun 21, 2014 by geonetadmin
Hello,

I have 2 adjoining DEM rasters that I have combined into a single, continuous raster using Mosaic To New Raster. The two source rasters overlap, and both have some 0 pixel values around their edges. Here's the overlap of one atop the other:

[ATTACH=CONFIG]34792[/ATTACH]

Here are the options I am using in the Mosaic to New Raster tool:

[ATTACH=CONFIG]34794[/ATTACH]

In order to deal with the overlap and the fact that some of the pixels at the edge = 0, I set the Mosaic Operator to Maximum. Raster values are in Meters and range from 0 to 1,683, so I use 32 bit unsigned as the Pixel Type. The mosaicked raster looks fine at the boundary. However, at the southeast edge, there is some odd banding that is happening in the display. This is how it looks at 1:125,000 scale, with 2 odd bands of pixels at seemingly odd ranges from the neighboring pixels:

[ATTACH=CONFIG]34795[/ATTACH]

One of the odd band of pixels goes away when zoomed in at higher scales, but one remains. Here it is at 1:60,000:

[ATTACH=CONFIG]34796[/ATTACH]

At scales higher than 1:1:57,311, both odd bands of pixels disappear and the raster looks "normal". Here it is at 1:50,000:

[ATTACH=CONFIG]34797[/ATTACH]

Why the odd display, and why only at smaller scales? Looking at these again, it appears as if the odd bands of pixels are "ghosts" of other parts of the raster.

Outcomes