AnsweredAssumed Answered

Magnifier didn't turn off in SDK 10.2.2 and 10.2.3

Question asked by littlelam on May 28, 2014
Latest reply on May 30, 2014 by geonetadmin
Hi,

we found a problem that sometimes Magnifier didn't turn off when finger leave the screen.

To regenerate the problem,
simply use Basemaps sample program and add a button in main.xml
<?xml version="1.0" encoding="utf-8"?>
<LinearLayout
  xmlns:android="http://schemas.android.com/apk/res/android"
  android:layout_width="fill_parent"
  android:layout_height="fill_parent"
  android:orientation="vertical">

  <!-- MapView layout and initial basemap and extent. -->

    <Button
        android:id="@+id/magnifier"
        android:layout_width="wrap_content"
        android:layout_height="wrap_content"
        android:onClick="toggleMagnifier"
        android:text="Magnifier Off" />

  <com.esri.android.map.MapView
    android:id="@+id/map"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent"
    mapoptions.MapType="Topo"
    mapoptions.ZoomLevel="13"
    mapoptions.center="33.666354, -117.903557" />

  
</LinearLayout>



and in com.arcgis.android.tutorial.basemaps.BasemapsActivity.java
add a function to on/off magnifier
  public void toggleMagnifier(View view) {
  if ( mMapView.isShowMagnifierOnLongPress() == true) {
   ((Button) view).setText("Magnifier Off");
   mMapView.setShowMagnifierOnLongPress(false);
  }
  else {
   ((Button) view).setText("Magnifier On");
   mMapView.setShowMagnifierOnLongPress(true);
   mMapView.setAllowMagnifierToPanMap(true);
  }
  }


After run the program,
1. click the button the enable the magnifier

2. long press the map and magnifier appear, keep hold on the same position for a while.

3. When the finger leaves the screen,
sometimes the magnifier still keeps in screen and does not turn off as the first attached image.

4. click the button to disable the magnifier(where mMapView.setShowMagnifierOnLongPress(false) would be called),
the magnifier still appear as the 2nd attached image.

Besides waiting for the next release to fixed this problem,
is there any workaround solution to remove the magnifier?

Thank you for your help!

Sally

Outcomes