AnsweredAssumed Answered

Why is Maplex making all my labels disappear?

Question asked by geonetadmin on Dec 16, 2013
Original User: lisa.mcravey

I've got a shapefile with 300+ points in it, and am trying to organise the labelling.

I installed a trial version of the Maplex extension licence, (I'm only using Arc 9.2,) as via some research I've come to the conclusion that this will give me many more options in terms of placement and conflict resolution, as I can't seem to get the desired effect with the standard labelling engine.

However, when I enable the maplex label engine, all my labels disappear, and I can't figure out how to get them back on? I get all the maplex options in terms of placement, but find it odd that I can't see a single label no matter what I click? I'm hoping there's a checkbox somewhere or extra step I have to perform before this will work, can anyone shed any light on this?

My labels are all showing fine using the standard labelling editor (though they all overlap, and I want to be able to fix them without converting to annotation and placing each individually, as there are so many!) But as soon as I enable Maplex, they disappear.

I have tried View Unplaced Labels, and still nothing shows, and also Never Remove Labels, and still nothing shows? And then if I disable Maplex, all my labels show fine again, though I lose all the Maplex controls I want to use. I've tried this in a variety of .mxd's with a variety of shapefiles, all with the same result. Not sure if I am doing something wrong, or if there is a bug with the trial extension? Can anyone help??

[ATTACH=CONFIG]29913[/ATTACH]
[ATTACH=CONFIG]29914[/ATTACH]
[ATTACH=CONFIG]29915[/ATTACH]
[ATTACH=CONFIG]29916[/ATTACH]

Note I have also posted this at GIS StackExchange: http://gis.stackexchange.com/questions/78874/why-is-maplex-making-all-my-labels-disappear

Outcomes