AnsweredAssumed Answered

Extend Line Tool Not Working?

Question asked by geonetadmin on Jun 6, 2013
Latest reply on Jun 10, 2013 by kaeldowdy
Original User: kaeldowdy

So, this is a continuation from my first post related to inaccurate matches at:, but I felt this question needed its own thread...

I have two simple line feature classes:  Leader Lines and Pipelines (color coding used to explain the screenshots).  The Leader Line feature might be either just "before" (Example 1) or "after" (Example 2) the Pipeline feature.  What I'm wanting to do is to extend or shorten the Leader Line to touch the Pipeline.  In my earlier post, I've already gone through the process of determining which Leader Lines aren't touching a Pipeline feature, so now I need to act upon the ones I determined were disconnected.

Example 1 (Leader Line ~ .5 mm away from Pipeline)


Example 2 (Leader Line ~ .38 mm past Pipeline)

I reviewed the Extend Line and Trim Line tools, and tried using the Extend Line tool on my Example 1 scenario Leader Lines, but I could not ever get the line to extend to the pipe.  Maybe I'm misunderstanding the usage of this tool (do all objects need to be within the same feature class or can they be different?)

I then tried merging these two feature classes together, and then selected the Leader Line and tried running the Extend Line tool, but no dice either.  The SHAPE Length remained the same.

Does anyone have any thoughts as to a different way to go about extending (or shortening) the line within a certain tolerance?  I'm thinking anything <= 1.0 mm would be a good start. 


EDIT 1: So, I'm making progress. When I mentioned earlier that I was "merging" the two feature classes together, I was actually using theUnion tool, but I found that if I used the Merge tool, and then run the Extend Line tool, it works!  Well, mostly...

When I run the extend on my leader line, the line extends past the pipeline and not exactly on the pipeline.  When I measure the little dangle, it's very small -- 0.000007 mm.  This might be an acceptable tolerance for some, but it still is not technically touching and I'm afraid I will run into issues later once I import this data back into my source system (GE Smallworld). 

I found that I needed to provide an XY Resolution and Tolerance of 0.00001 mm whenever I run the Merge and then the Extend Line works on the output geodataset from the Merge. 

Is it possible that my feature classes which go into the merge need to be recreated with a certain level of precision to allow for subsequent processes to be more accurate?  I'm just wondering if we need to reexamine how the initial geodatasets are even being created. 

Otherwise, is there a combination of settings for the XY Resolution and Tolerance needed to make the Extend work as desired?