AnsweredAssumed Answered

AutoCAD DWG fields missing in Workbench

Question asked by geonetadmin on Apr 30, 2013
Latest reply on May 1, 2013 by MDonnellyesriaustralia-com-au-esridist
Original User: mdonnelly

Hello,

I am using Data Interoperability in Desktop 10.1 SP1 (Workbench 2012, SP3).

I am trying to create a tool, that writes to an AutoCAD DWG file.

When I look at any DWG feature type there are no user attributes, just format attributes to expose. This means I can happily expose attributes such as fme_rotation to write to but other attributes, such as RefName are not available. RefName exists as an attribute in the output DWG.

Let me say that having run the tool that it does work, in that all the features are copied to the output DWG and if I have set a format attribute, that too is copied. It's just that I need to set other attributes in the output DWG but cannot get to them.

I'm sure that I'm missing a simple setting somewhere to expose these attributes but I can't locate it myself (despite googling, etc).

Things I've tried, that didn't work:

- Adding a User attribute manually, that matches the attribute name on the DWG file.
- Setting the Advanced option on the Writer: Output Defined Attributes Only = No.

Any advice would be welcome.

This image is of the DWG Polygon layer attributes viewed in Desktop:
[ATTACH=CONFIG]23890[/ATTACH]  

This image is of the FME Workbench showing that there are no user attributes exposed:
[ATTACH=CONFIG]23891[/ATTACH]

Regards,

Mark

Attachments

Outcomes