AnsweredAssumed Answered

cannot import features into an Oracle Geodatabase after a raster import failure...HEL

Question asked by jwfox1 on Apr 12, 2013
Latest reply on Apr 14, 2013 by geonetadmin
I attempted to import a small test raster dataset from a local file geodatabase into an Oracle 10g Geodatabase. After the failed raster import attempt I find I cannot import any other vector features into it as well.  The errors I am getting are the generic oracle ORA "function passed invalid parameters" and/or "index not in range" or "locator not found" errors, which if you are not an ESRI developer or SDE data expert really tell you nothing!!! These look a little like the errors you get when you abort or crash an edit session and leave A and D tables in your schema but I was not doing editing but just importing a raster layer (that was quite tiny - less than a MB!). There are no DB locks held and I bounced the oracle database.  I tried feature class import, export (from the other geodatabase) and cut and paste. Same errors occur!

I have not tried ArcMap editing of current features yet but I am fearing if this capable is now gone also.

If some overall spatial parameter has been accidentally reset by this failed raster import attempt, or something in the schema or SDE metadata has been corrupted please tell me how to clean this up and fix it. I am new with working with raster datasets and layers at the data layer.


Oracle 10g (10.2.0.4) database, ArcSDE 9.2 and ArcDesktop 10.0


Thanks, 


-James W. Fox

Outcomes