AnsweredAssumed Answered

NoData Value issue in Clip in Data Management-> Raster->Raster Processing

Question asked by geonetadmin on Feb 6, 2013
Original User: xiannian

Hi, friends,

I met a situation while clipping raster. The function I use is in Data Management ->Raster -> Raster Processing.
The Input Raster is a Mosaic Dataset with three bands: RGB. The Output Extent is a polygon I specify.  I want the output file extension to be JPG. The others are straightforward.

The problem happens at the NoData Value option. As a matter of fact, there is no anywhere/any pixel in the mosaic dataset. How should I set this NoData Value option? I have tried several choices: leaving this box blank, putting "NoData" in the box, putting ",," in the box because I think there are three bands, putting "NoData,NoData,NoData" in the box because I think there are three bands. Every time, the CLIP function returns me many NoData pixels, which are not correct.

I have attached two screenshots. The first one is the original, and the other one have so many blank pixels.
So, the original data has no NoData pixels at any channel/band. It does have many pixels which have 0 or 255 kind of values at some channel/band. How should I set the NoData Value option in CLIP to have the CLIP function to just clip the image without changing the pixel values?

Thanks in advance,

[ATTACH=CONFIG]21493[/ATTACH]
[ATTACH=CONFIG]21494[/ATTACH]

Outcomes