AnsweredAssumed Answered

wrong extent for mosaic dataset after editing footprints

Question asked by geonetadmin on Dec 2, 2012
Latest reply on Dec 6, 2012 by ncurri
Original User: ncurri

I created a mosaic dataset to display tiles of the 7.5 minute USGS DRGs, covering an area of about a 320 square mile areas. The scanned DRGs have already been edited so that the marginal information is gone, broken up into smaller tiles, georeferenced and aligned. I only want to display the tiles (and/or the portion of tiles) that cover my study area - nothing outside.

At an earlier time, I would have simply mosaic'd these images into a new raster layer in a file geodataabase, then clipped the raster to my study area boundary. I still might do that, since it's not a huge dataset, but the fact that I'm getting this particular issue when trying to do it the mosaic dataset way is leading me to believe I may have got something wrong.

So, after creating the mosaic dataset, I edited the footprints, first by deleting the footprints that fall completely outside of the study area. The build boundary tool correctly recalculated the new mosaic boundary, then I ran build overviews and everything was fine. But I noticed that when I "zoom to layer" no the mosaic dataset, it would still zoom me out to the extent before editing the footprints and rebuilding the boundary. I also thought that I should be able to "clip" the footprints layer to my study area and display only the interior portions of the tiles that overlap the boundary of my study area.

After a little searching, I came across the "import mosaic dataset geometry" tool, described in the online help here (http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//009t000001v0000000Set) as part of a process to replace the calculated footprints element with one of your choosing. I thought this could take care of both of my problems. I used it replace the existing footprints layer with a clipped version. This worked, and once I built the overviews it correctly displayed only the imagery within the clipped footprints. However, the old zoom extent remained. This time, though, I noticed that If I zoom to extent of the Boundary or Image element of the mosaic dateset, it zooms to extent of the clipped footprints layer. But if I zoom to the Footprint element or zoom to layer on the name of the mosaic dataset, it zooms me back out to the original extent again.

Here's the footprints and boundary for the original mosaic dataset with all tiles (using default symbols), showing the study area boundary (thick black outline).

[ATTACH=CONFIG]19657[/ATTACH]

Here's the mosaic dataset, displaying the images after replacing the footprints with the clipped version, recalculated the boundary, and built overviews - but still zooms to original extent when I zoom to layer.

[ATTACH=CONFIG]19658[/ATTACH]

Outcomes