AnsweredAssumed Answered

Geoprocessing Service Result Map Service Labels

Question asked by sdrummond-esri-ca-esridist on Nov 28, 2012
Latest reply on Oct 14, 2016 by valraa
Hello,

I�??m working on a geoprocessing service that returns a layer as an output. This layer is going to be rendered in the ArcGIS Viewer for Silverlight (3.0.1) and needs to be symbolized with graduated colors and needs to be labeled with values from one of the attribute fields (frequency).

I have successfully published this geoprocessing service and have been consuming it in the viewer. The results are returning correctly symbolized but I�??m have not been able to successfully return the labels. According to the documentation in the link below; when the result of a geoprocessing service is returned as map service, �??The symbology, labeling, transparency and all other properties of the return map are the same as the output layer in the current ArcMap session.

http://resources.arcgis.com/en/help/main/10.1/index.html#//00570000007t000000

I must be missing something.  I can view the map service that supports the geoprocessing service and see the features labeled:

[ATTACH=CONFIG]19591[/ATTACH]

I can navigate to the rest services and I see that the �??Has Labels�?� property is set to true. However, the result of the geoprocessing service does not display the labels:

[ATTACH=CONFIG]19592[/ATTACH]

When I navigate to the rest end point for the �??job result service�?�. I can see that the layers �??Has Labels�?� property is set to false.

Has anybody had any experience with this that might be able to point me in the correct direction? Am I miss interpreting what the documentation means when it suggests that �??Labels�?? are returned?

Regards

Sam

Attachments

Outcomes