AnsweredAssumed Answered

Overlapping orthos in mosaic dataset and ZOrder

Question asked by ncurri on Nov 24, 2012
Latest reply on Dec 4, 2012 by JSwain-esristaff
I've created a mosaic dataset for orthophotos for two adjacent towns. There are several overlapping tiles along the town boundary, and the tiles in each town are different sizes. This shouldn't be a problem for a mosaic dataset from what I've read - however, after following the work flow http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/The_workflow_and_tools_to_create_mosaic_datasets/009t00000039000000, there are gaps along the town boundary where the tiles overlap... But only over some:

[ATTACH=CONFIG]19501[/ATTACH]

If I load the individual tiles where the gaps appear, it seems that some of the larger tiles along the boundary include white space in the actual image. The screenshot below shows one of the tiles with white space obscuring the mosaic dataset "Footprint" boundaries for the smaller tiles.

[ATTACH=CONFIG]19502[/ATTACH]

So, from what I understand about how the ZOrder field in the "Footprint" boundary is supposed to work, if I set the value lower in the small tiles and a higher for the larger tiles, the smaller tiles (with photographic information throughout the space) should display on top and the larger tiles should be the background. So, I set ZOrder = -1 for all the smaller tiles and 1 for the larger tiles. That seemed to work, but then I when I built overviews and zoomed back out I see the same gaps, though they have shrunk a bit (compare to the first screenshot).

[ATTACH=CONFIG]19503[/ATTACH]

I found a post in the forums describing a problem that seemed to be similar to what was happening for me (http://forums.arcgis.com/threads/48759-Mosaic-dataset-overviews-appear-black-have-gaps-in-some-parts?highlight=mosaic+raster+gaps). So, I followed the advice written in by gsumerling and recreated the mosaic again, this time running the Build Footprints tool after loading rasters into tthe mosaic, though that seems redundant since I had "Update Cell Size Ranges" and "Update Boundary" boxes checked in the Load Rasters window (I also had calculate pyramids and statistics checked, and was careful to leave "Update Overviews" unchecked). Then, I ran Build Overviews and did NOT edit the ZOrder field in the table. Got the same result as in the first screenshot.

Can anyone see where I'm going wrong in the process, here?

Outcomes