AnsweredAssumed Answered

Hotspot (Getis Ord Gi*) and ISA script Error:"<type 'exceptions.AttributeError'>:..."

Question asked by p_kohler on Sep 20, 2012
Latest reply on Sep 24, 2012 by mjanikas-esristaff
[ATTACH=CONFIG]17847[/ATTACH][ATTACH=CONFIG]17848[/ATTACH][ATTACH=CONFIG]17849[/ATTACH][ATTACH=CONFIG]17850[/ATTACH]Hi,

I'm using ArcGIS 10 (service pack 4) and getting the error below whilst using the Hotspot (Getis-Ord Gi*) tool and the downloadable Incremental Autocorrelation Script (ISA):

<type 'exceptions.AttributeError'>: DescribeData: Get attribute extent does not exist
Failed to execute.


ISA Script Iâ??m using available from here http://www.arcgis.com/home/item.html?id=694e0f97355740d7bba6b8b356c0b925

Aware there are number of threads reporting problems with ISA tool, and with similar error, and that it is available as part of 10.1.

In my case, both scripts are in their own geoprocessing models, with inputs supplied via a Copy, Integrate and Collect Events setup. See screenshots.

I managed to get around this the error briefly with the ISA model by defining the study areaâ??s Extent in the Environmental Settings (named "Extent", see attached). I could then run the model in the model window only, using the dialogue would set off the error. However, this was only temporary, I then setup the hotspot model as shown and got the same error â?? irrespective of which â??viewâ?? I tried to run it in Model or Dialogue in. Returning to try the ISA model again, it also stopped working in both â??viewsâ?? and I havenâ??t been able to get either working now.

Can anyone advise?

Best Regards

Peter

Outcomes