AnsweredAssumed Answered

WMS: Blank image returned, Feature Count: 0

Question asked by geonetadmin on May 26, 2011
Latest reply on May 27, 2011 by geonetadmin
Original User: yohanb

I'm trying out the ArcGIS API for Flex sample called WMS Layers on/off

I already have a MapService with the WMS capability running in my ArcGIS Server 10 SP2 and tried replacing the URL in the sample with my own, as a test. My URL looks like this:

http://AZIVMYOHAN01:8399/arcgis/services/POC_BROMONT_THREE_LAYERS/MapServer/WMSServer?EXCEPTIONS=INIMAGE

My service is started and I also see it in my rest/services page

So when I run the sample with only this modification, the only thing the server sends back are blank images of the width and height specified by the WMS GetMap request.

I spent hours trying to figure out what's wrong, I've inspected the log files in verbose mode (using Eclipse's LogViewer plugin for highlighting) and there's isn't any error . The server says it's successful in serving the binary request but always ends up with a result of 5673 bytes, which is a black png of size 1380x730.

On the rest services page is says the EPSG is 3395, so I also tried forcing the CRS to 3395 in the WMS request sent from the sample code to match since otherwise it was sending 4326. It didn't help.

When I add my service in ArcGIS Explorer, as a test, the layers are displayed properly. Although they are displayed as one (I can't turn on/off specific layers).

I'm hoping someone could give me a clue or tip on how I could figure out why the server is returning blank images. I'm out of ideas. One thing I have noticed in the logs, is that the Feature Count is 0. If that is the reason why the images are blank, then the question is: why is it 0?

I have included a log excerpt, the XML returned for the GetCapabilities request, a screenshot of my rest services page and a screenshot of the GetMap query sent.

Thanks

Outcomes