AnsweredAssumed Answered

Topology Validation Errors: Circular Patterns

Question asked by goh_raj on Mar 17, 2011
Latest reply on Mar 31, 2011 by geonetadmin
We are currently using ArcGIS Desktop 10 SP1 ArcInfo.  When we validate topology, we notice that the "Area Errors" are coming up in the form of circular shapes (see screen captures).  There are no errors whatsoever in these areas and there is no reason why we should be seeing these oddities.  The underlying data is not affected so far, but we are having a very difficult time validating our data.  Some people in our group cannot even validate topology anymore and are seeing error 109 or error 140 every time they validate, at every extent and no matter where they pan.

We are encountering the following two errors:

Validate Topology failed.
A failure was detected inside the topology engine overlay processor. [error id: 109]

Validate Topology failed.
A failure was detected inside the topology engine. [error id: 140]


This issue is reminiscent of an earlier issue in 9.2 or 9.3 where running topology would create these circular shapes BUT it would also warp/modify the underlying data to reflect these circular patterns. It was a nasty problem. Our actual parcel polygon layer would suddenly have fish scale or scallop patterns everywhere.  ESRI then released a critical patch to fix this and then we were back to normal.  Now in 10 SP1, it seems like this issue (or some form of it) is coming back!  Luckily our data is not affected, but we are seeing error ids: 109 and 140 pop up all the time now.

What should we do?  What are these errors?

Thank you.

Outcomes