AnsweredAssumed Answered

Error in "Flow Direction with Sinks" on Arc Hydro 2.0

Question asked by Alvaro-DK on Feb 15, 2011
Latest reply on Sep 13, 2012 by geonetadmin
Hello again

I can see there are 46 views on my previous thread about Flow Direction with Sinks, but no reply at all :(

I have now formatted my computer, and re-installed Windows XP with the latest service pack. I have also installed Arc Hydro 2.0, with the hope of losing the problem, but I am close to concluding there is an error in the code (visual basic programming) of this function. Could it be? Here´s a description of what I have done:

- I have a GRID raster file (5x5m) covering an area of about 460 km2 (Uncompressed size: 71.20 MB). Format: Continuous Double Floating 32-bit
- I have two feature datasets: a polygon layer for lakes, and a polyline layer for streams
- I create my geodatabase (gdb file) and the corresponding target locations for my results
- I run the Terrain Pre-processing functions, to which I get the corresponding results: LevelDEM, AgreeDEM, etc. My focus is on Depressions, rather than Sinks, so I use the Depression Evaluation function, and I produce my filled DEM using these depressions. So far so good.

- The problem comes when I run the function Flow Direction with Sinks, using my Depression polygon layer and my filled DEM. I am attaching two pictures of what it seems to be the same error, both when I run it directly from the Arc Hydro toolbar and when I run it from a Model using the Arc Hydro toolbox.

As you can see, the error points to what it seems to be a very generic error in visual basic programming, namely something with "System.Runtime.InteropServices.SEHException: External component has thrown an exception". Or, from my attempt with model builder: "Error HRESULT E_FAIL has been returned from a call to a COM component". Then, in both pictures, the error refers to a path, which does not exist on my computer: C:\Projects:\10_Final\ArcHydroTools\src\ApHydro\ArcHydroOp.vb:line 4356

As mentioned, I do not have a folder called 'Projects' on my C drive. What is happening? Is Arc Hydro attempting to write or get data from a path which does not exist, and therefore the function crashes? If so, why is it doing that and how I can change it?

Finally, a quick comment. I have 5,025 depressions where the attribute IsSink is set to 1. Therefore, these are the depressions that Arc Hydro uses to calculate the flow direction with sinks. As you can see from the error messages, in the end of the (unexisting) path, it says line:4356 and line:4358, respectively. This matches well with what I could see from the Geoprocessing model window, where it said that the Sink Point layer was about 78% done, just before it crashed.

I should mentioned, to finish, that this is the first time I have had problems with Arc Hydro, more specifically with the Flow Direction with Sinks function. About 3 months ago, running with Arc Hydro 1.4 on ArcGIS 9.3.1, I ran exactly the same workflow, with no problems at all, on the same computer. I actually formatted the computer in order to start "from scratch" with my new ArcGIS 10 and Arc Hydro 2.0. Unfortunately, it has not worked.

Any help would be deeply appreciated. Kind regards to everyone, keep up the good work :)

Outcomes