AnsweredAssumed Answered

Area Solar Radiation: Failed to open raster dataset

Question asked by geonetadmin on Nov 19, 2010
Latest reply on May 23, 2016 by salmanseahmed3
Original User: Greforb

I tried to do some calculations on solar radiation in ArcGis 10. I use the Area Solar Radiation tool, and no matter what settings I use, I keed getting the error: Failed to open raster dataset. I Tried doing it both in ArcMap and in Python, using the following command:
AreaSolarRadiation("K:/Raster/dem.img","45,0","2800","WholeYear   2009","14","0,5","NOINTERVAL","1","FROM_DEM","32","8","8","UNIFORM_SKY","0,3","0,5",'','','')

I get the full error:
Traceback (most recent call last):
  File "C:\Users\Gis\Desktop\vg.py", line 7, in <module>
    AreaSolarRadiation("K:/Raster/dem.img","45,0","2800","WholeYear   2009","14","0,5","NOINTERVAL","1","FROM_DEM","32","8","8","UNIFORM_SKY","0,3","0,5",'','','')
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Functions.py", line 5953, in AreaSolarRadiation
    out_direct_duration_raster)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Utils.py", line 47, in swapper
    result = wrapper(*args, **kwargs)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\sa\Functions.py", line 5933, in wrapper
    out_direct_duration_raster)
  File "C:\Program Files (x86)\ArcGIS\Desktop10.0\arcpy\arcpy\geoprocessing\_base.py", line 474, in <lambda>
    return lambda *args: val(*gp_fixargs(args))
ExecuteError: ERROR 999999: Error executing function.
Failed to open raster dataset
Failed to execute (AreaSolarRadiation).

From which it seems to be the out_direct_duration_raster which is causing the trouble. However, this is optional, so I don't get why. I tried giving it a path for the out_direct_duration_raster, which does not help either.

I also tried to do a repair of the installation because I read somewhere else here on the forums that that might help. No luck though!

Any suggestions are greatly appreaciated

Attachments

Outcomes