AnsweredAssumed Answered

SQL Server and Float values

Question asked by rmcculley on Sep 4, 2014
Latest reply on Sep 8, 2014 by rmcculley

I'm working on creating an Enterprise GeoDatabase in SQL Server 2012, but I'm having a problem with float values.


The GeoDatabase was created using the Create Enterprise GeoDatabase tool.  The user being used to connect is the "sde" user.


I've got a table with the following fields:

LINC - Text

OwnerName - Text

TenancyGroup - Text

TenancyInterest - Float, Precision 4, Scale 3

OwnerAddress - Text



The TenancyInterest column stores a percentage value ranging between 0 and 1, with three decimal places.  When I view the table in ArcGIS, the float value always displays as 0.  Further, the OwnerAddress and GlobalID columns both display as empty.  I'm populating the table using an arcpy script.  If I don't populate the TenancyInterest column, then the OwnerAddress and GlobalID column both display the correct values.


If I edit the table and manually enter new values, there is no error message, but the value still displays 0.  I tried creating the table in a File GeoDatabase, where everything worked fine.  I then imported the File GeoDatabase table into my SQL Server GeoDatabase, and ended up with the same result: float values all showing as 0, remaining columns showing as empty.


I tried creating the empty table, and inserting one record in ArcGIS.  I've tried using Float and Double for the data type.  I've tried not setting the Precision and Scale (apparently it defaults to 38 and 8).  Same result.


If I view the table in SQL Server Management Studio, all of the values are in the table correctly.  I can see the proper percentage value in the TenancyInterest column, and I can see the proper Text in the OwnerAddress column.  When I edited the data manually in ArcGIS, the changes show up in the table in Management Studio, even though they aren't displayed in ArcGIS.


Any ideas on what I'm doing wrong?