AnsweredAssumed Answered

Howto import CSV-file to ArcMap

Question asked by HimBromBeere on Sep 3, 2014
Latest reply on Sep 3, 2014 by HimBromBeere

when trying to import a CSV from my hardtrive to my map-document using "add Data"-dialog I get the error "Selected element could not be added to map. Generic error" (or something similar, I am using german version, so actual message may vary). When doing the same via TableToTable_conversion-tool in GP I get the error 000732: Dataset 'myFile.csv' not existing or not supported. I also tried to create a file-GDB and import the table there, result is the same.

 

Here is my CSV-structure:

SID,UUID

1,DENW22AL60001dVy

1,DENW22AL30000FLl

 

I also tried with semicolons rather then single comma as delimiter, but can´t get it working. Also notice that I only want a standalone-table rather then a featureclass. Therefor no coords are given within the file.

 

EDIT: As of Error: 000732: Dataset does not exist or is not supported this error may occur if the file-name itself is incorrect. So I did the proposed corrections for filenames (use forward-slashes, no spaces) but with no avail. Also since I chosed the file by the file-dialog rather then by typing its name I did not even expect this would do the trick (just for completeness).

 

I´m using ArcGIS 10.0 (SP5) for Windows 7 (64Bit)

Attachments

Outcomes