AnsweredAssumed Answered

Why does ArcGIS Server geocode service output wrong SRS when f=kmz?

Question asked by whimbrel on Jul 29, 2014
Latest reply on Jul 30, 2014 by whimbrel

We use the ArcGIS Server geocoding service in vMaine to get locations for addresses entered in Google Earth Enterprise.  This worked fine in the 10.1 days.  However what happens now is that, despite specifying the outputSRS, it returns the coordinates in UTM when you specify KMZ.  For example, this request will return the correct lat/long:

 

http://arcgisserver.maine.gov/arcgis/rest/services/NG911_Rds_Locator/GeocodeServer/findAddressCandidates?Street=100+Lincoln+Ave&City=Gardiner&outSR=4269&f=html

 

which should be -69.77233, 44.22248 and is my house in Gardiner.  The HTML gives the correct lat/long (also if I do JSON that works too).  Yet if I specify the output to KMZ, like this:

 

http://arcgisserver.maine.gov/arcgis/rest/services/NG911_Rds_Locator/GeocodeServer/findAddressCandidates?Street=100+Lincoln+Ave&City=Gardiner&outSR=4269&f=kmz

 

and I open the KML file in Google Earth, it takes me to 0,0 lat/long (Atlantic Ocean south of Ghana).  If I look at it in a text editor, I see this:

 

<tr><td>Score</td><td>100</td></tr>

<tr><td>Match_addr</td><td>100 Lincoln Ave, Gardiner, ME</td></tr>

      <Point>

<coordinates>438310.9883381335,4896873.130619503,0</coordinates>

      </Point>

 

which you can see the coordinates are clearly UTM, not lat/long and hence the reason Google Earth can’t deal with it correctly.

 

So ArcGIS Server is correctly geocoding the address, it correctly outputs the lat/long to HTML, but if that ‘f’ parameter is changed to KMZ it provides the UTM instead.

 

Do you have any suggestions?

Outcomes