AnsweredAssumed Answered

ArcGIS for Desktop 10.2.1 and PostgreSQL 8.0.1 compatiblity issues

Question asked by wysek on Jul 18, 2014
Latest reply on Jul 19, 2014 by vangelo-esristaff

Hello,

 

I'm currently working with an infrastructure built with ArcGIS 10.0 (Desktop and Server) [SP2 build 3200] and because for some functionalities (ArcGIS for Desktop extensions) I need to use a newer version I'm testing how the ArcGIS for Desktop 10.2.1 copes with the current infrastructure built with 10.0. And so far it copes quite poorly...

 

I guess my biggest problem is following: there's an ArcSDE geodb set-up in PostgreSQL 8.0.1 which works perfectly with the 10.0 desktop version with appropriate client files installed according to the manual. Unfortunately the newer version happen to be more troublesome. I installed client files for my version of ArcGIS for Desktop and PostgreSQL 9.0.5 (which is the oldest version of postgres for which the client files are available). If I want to connect to the ArcSDE inside the db in ArcCatalog the connection window, as in here, hangs on listing postgres databases under requested instance. So I tried another approach. I copied the connection file from the older version. The db is recognized and listed as "Application Server" and the connection is successful up to a certain point. If I want to access (through a direct connection from ArcGIS for Desktop 10.2.1) any raster stored in the geodb, both ArcCatalog and ArcMap crash without any warning or error. Vector layers and tables work OK. What's interesting is that the connection is successful and behaving as described whether or not the client files are installed.

 

The operating systems are: Windows 7 SP1 x86 for the 10.0 version and Windows XP SP3 for the 10.2.1 version. I've also tried client files from the 10.0 version, but the result has been the same. Has anyone encounter such behaviour? Is what I'm trying to do possible?

 

I do not have RDBMS files installes as I'm not sure what are they for.

 

Cheers,

Michal

Outcomes