(Simple) Geometries getting "corrupted" when syncing

Discussion created by jmargul on Jul 1, 2014
Latest reply on Jul 9, 2014 by khodge-esristaff
Hi everyone,

Before I begin crying for help, here is my setup:

  • AutoCAD 2013 / Plugin 350 and AutoCAD 2012 / Plugin 300 (tried both)

  • SQL Express 2012

  • ArcGIS Server 10.2

  • ArcMap 10.2

  • Feature Services running with editing enabled and Geometry Updates/True Curve Updates enabled/disabled (tried both)

  • Features in ArcMap have default values for certain attributes, if this is worth mentioning

I've drawn some very simple lines (open and closed) in AutoCAD. When attempting to copy and therefore synchronize them to existing feature classes from a feature service, the sync runs with no errors reported.

However, when the features then refresh on screen/re-download, they are corrupted in various ways: start/end points are shifted; closed polylines become open; lines are "rebuilt" (to use a Rhino term, sorry) with 100's of vertex points added. Upon then trying to display the feature services then in ArcMap, sometimes all that will show is a single point. Trying to add the Map Service in AutoCAD yield a blank display, even if the Feature Service displays (not correctly, but still displaying).

I can't figure out quite what is going on. There are many moving parts, between CAD, ArcMap, ArcGIS Server, SQL, oh my...

I searched and found other threads where problems seemed to relate to more complex curves, and even then, the most recent update (350) was supposed to take care of those.

Any suggestions would be extremely appreciated. If it were of use, I could also share the CAD file. As an example of the geometry "corruption," attached is a screenshot of what should be four simple lines meeting at one point, and what happened after sync.