nilsrinformi-dk-esridist

Problem upgrading from 10.2.0 to 10.2.2: adapter says "Invalid stream configuration"

Discussion created by nilsrinformi-dk-esridist Employee on Jun 20, 2014
Latest reply on Aug 19, 2015 by slmeier
I have created a custom adapter for reading AIS data in Denmark, the source code is available on GitHub: https://github.com/pilsna/ais-for-geoevent.
The adapter is implemented for GeoEvent 10.2.0 and I've been running it successfully for a couple of months.
This week I've been trying to install it on a 10.2.2 server, and I receive the following error:
com.esri.ges.rest.stream.internal.OutputRestAdminServiceImpl
Invalid stream configuration: stream name is required.
Fri Jun 20 10:13:33 UTC 2014
ERROR

I can create a connector using the AIS adapter, the error appears when I try to add a new Input. Screenshot:
[ATTACH=CONFIG]34760[/ATTACH]
I've tried to raise the log level, with no success.

What can I do to dig deeper and find the cause of this error?

/Nils

Outcomes