AnsweredAssumed Answered

ArcSDE 10.1 sp1 upgrade geodatabase error: DB_arcsde_setup: Unable to connect

Question asked by grsamit on Apr 8, 2014
Latest reply on Aug 15, 2014 by dmcalister
Hi All,

While trying to upgrade my ArcSDe geodatabase from 10.1 to 10.1 sp1 with Oracle getting below error as recorded in the SDE_Setup log file.

[Tue Apr 08 14:33:21 2014]
ST_Geometry Schema Owner: (SDE) Type Release: 1007
[Tue Apr 08 14:33:21 2014] Instance initialized for ((sde)) . . .

[Tue Apr 08 14:33:21 2014] Error: Underlying DBMS error (-51).
[Tue Apr 08 14:33:21 2014] Error: DB_arcsde_setup: Unable to connect
[Tue Apr 08 14:33:21 2014] ORA-00933: SQL command not properly ended

[Tue Apr 08 14:33:21 2014] ERROR installing/upgrading ArcSDE, Error = -51

User privileges for geodatabases in Oracle are verified from the below webhelp link:
http://resources.arcgis.com/en/help/main/10.1/index.html#//002n0000002v000000

Also I connect to the geodatabase as ArcSDE admin user (SDE), run the following query and attached is the exported file which looks good:
select object_name, object_type, created, last_ddl_time, status from user_objects where object_type in ('OPERATOR','PACKAGE','PACKAGE BODY','INDEXTYPE','FUNCTION','TYPE','TYPE BODY');

referred the below forum link:
http://forums.arcgis.com/threads/18033-ArcGIS-10-Upgrada-Geodatabase-Error

Attached is the exported file for your reference.

Any suggestion is appreciated.

Regards,
Amit

Attachments

Outcomes