zeqrcat

Custom Toolbar Tools (Python Script - Geoprocessing) Not Saving as Customization

Discussion created by zeqrcat on Mar 18, 2014
Latest reply on Jan 19, 2018 by spawkly
I am having an issue, (previously with 10.1 and now with 10.2) where custom tools that I have placed into a toolbar (either custom or default) are not being saved in the default customization document. I've noted important points below:

Versions:

  • 10.1

  • 10.2

Summary:

  • Custom tools were created as custom commands

  • These were added through the [ Geoprocessing Tools ] category by using the "Add Tools" button and selecting a previously created python script

  • After saving a new document, and reopening ArcMap, the custom tools were no longer present

Important Notes:

  • Saving a stock (ERSI) tool in the same toolbar at the same time causes only the custom tools to disappear, not the stock one

  • In customize mode, the options "Save all customizations to the document" and "Create new toolbars and menus in the document" have both been tried as checked and unchecked, and yielded no results

  • Saving the tools in a standard or custom toolbar makes no difference

  • The tools are preserved in the document that was saved but this is not a feasible way to distribute custom tools.

  • When in customize mode after saving the tools and opening a new document, looking at the commands under [ Geoprocessing Tools ] shows none of the tools that were added previously


I began a discussion on stackexchange here, which shows that at least one other person had the same issue in 10.1

ESRI Documentation for Creating Custom Tools:

Is this a common bug, a rare bug, or am I doing something wrong? I'm fairly sure I've followed all the right steps in the documentation. Below is a screenshot of what the toolbars look like before and after.

[ATTACH=CONFIG]32279[/ATTACH]

Attachments

Outcomes