sip15

No success with ArcGIS Server 10.2 on Red Hat Enterprise Linux 6.5

Discussion created by sip15 on Jan 17, 2014
Latest reply on Jan 21, 2014 by bubbahey25
I'm new to ArcGIS server - I followed all installation instructions on the ESRI site for RHEL:

- Installed xorg-x11-server-Xvfb
yum install xorg-z11-server-Xvfb
- Installed ArcView server in /home/arcgis
./Setup -m silent -l yes /home/arcgis/licence.ecp
- Copied the arcgis for server startup script to the rc.d startup folder and did the mods
cp /home/arcgis/server/framework/etc/scripts/arcgisserver /etc/rc.d/init.d
added # chkconfig 35 99 01
chkconfig --add arcgisserver
chkconfig arcgisserver on

It then says that after a reboot you should be able to reach the management interface with
http://<server name>:6080/argis/manager

I checked if a service was running on the local machine and listening on that port
telnet localhost 6080

But connection timed out

After crawling through the code I see that tomcat is not running - nothing is said about starting the locally provided tomcat in the guide - so I found where to start this

/home/arcgis/server/framwork/runtime/tomcat/bin/startup.sh

Now i see its listening on port 6080

I try again and I see a web page starting with "Please Wait" that won't go away

I check the error console and I see lots of errors related to help not funding en-za (english locale for South Africa)
I copy the /home/arcgis/server/help/en to /home/arcgis/server/help/en-za

Now the loading page get a little further - but there are many object errors related to dojo.js:15 - see attached dump of the web console.

Am I missing something obvious here

Thanks
David

Attachments

Outcomes