AnsweredAssumed Answered

Error in printing Buffer with parcels highlighted in graphics layer

Question asked by carvul on Nov 5, 2013
Latest reply on Nov 2, 2017 by billfox
Good afternoon forum friends!

I was hoping someone could help us with a.   Our current software version is ArcGIS Server 10.1 and we are using the ESRI JavaScript 3.6 API.

We have two major issues 1) printing text symbol graphics when exporting a map and 2) we get an error in printing when we buffer a parcel and trying to print all the highlighting graphics layer to a map. 

1) Text Issue: When printing a map with graphic text symbols the graphic is not captured there for it will not display on the printed map.
We are not seeing any error issues it just appears that the graphic is not being captured. 

2) Buffering issue:  We get an error in printing when we buffer a parcel and trying to print all the highlighting graphics layer to a map. 
Error message:  JS ??? Error:
"Error executing tool.: Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task)."




Print Task Snippet:
//CREATE PRINT TEMPLATE
    var template = new esri.tasks.PrintTemplate();
    template.exportOptions = {
        width: 530,
        height: 620,
        dpi: 96
    };
    template.format = "jpg"; // pdf | png32 | png8 | jpg | gif | eps | svg | svgz ;
    template.layout = "MAP_ONLY";
    template.preserveScale = true;
    template.showAttribution = false;

    //CREATE PRINT PARAMS
    var params = new esri.tasks.PrintParameters();
    params.map = pMap;
    params.template = template;

    //EXECUTE PRINT
    if (printTask) {
        printTask.execute(params, getMapImageForPDFResult, getMapImageForPDFError);
    }


JS ??? Error:
"Error executing tool.: Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Layer "map_graphics": Invalid r value in color: 0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task)."

[ATTACH=CONFIG]28882[/ATTACH]

Attachments

Outcomes