AnsweredAssumed Answered

sderaster | load tiffs to raster catalog - NAME not found

Question asked by DavidHaberkorn on Jul 31, 2013
Latest reply on Aug 2, 2013 by vangelo-esristaff
Hi all,

I got a sde command from my colleague to load TIFFs into a raster catalog in sde (sitting on top of SQL db, ArcGIS 9.3 SP1). That's the command basically (refer to attached picture for more details):

for %%f in (%loc%\*.tif) do sderaster.exe -o insert -l %catalog%  -f %%f -n %%f -c jpeg -q 50 -L -1 -I nearest -t 128,128 -G 2193 -i 5151 -s TSTSDE01 -u USER -p PASSWORD


The command basically works fine, the tiffs are uploaded and look okay. The problem that I have is that the file names are not transferred, meaning that my rasters in the catalog do not have a name, only ObjectID. When running the command I get the following warnings:

Warning: column ARC_FM.Test.NAME not found. Warning: image name ignored.


Now I tried to add the parameter '-n' and add either a string or '%%f', but it would not change anything. I also tried to use '-o import' instead of '-o insert', but that would give me the error
Warning: Image name will be truncated. Error: Table already exists. Incomplete...


I already checked the SDE command documentations as well as other posts, like this one, played around with all kind of different combinations, but I did not yet come across a working solution.

My apologies if this may be a trivial question, but I haven't used SDE commands before and therefore am kind of stuck right now.

Thanks for any suggestions.

Cheers,

David

Attachments

Outcomes