hnaulty

ActiveX Control Error

Discussion created by hnaulty on Mar 1, 2013
The error I'm referring to: â??â?¦ threw an exception of type 'System.Windows.Forms.AxHost.InvalidActiveXStateException'â??

I have the ArcDesktop version 10.0 and the .Net SDK version 10.0 installed on my machine. I'm trying to use ArcEngine controls embedded in WPF to display the Map Control. I found out that if the controls are embedded in a page that is called via the NavigationService in the WPF application, the error gets shown immediately and the application doesn't even compile. I then went through the examples I found online and pulled the page out of the application and made it a window. That seemed to work. I then got a blank window. I traced through the code and found out that when the application got to the controls in the code behind that it skipped right over them. I then actually stepped into the LoadMxFile Control and found out that the error is coming up everywhere along with licensing errors even though I bind to EngineOrDesktop in the App.xaml file. I have used Google and searched quite a bit, but I have found no answers to my problem. I've tried using .Net Framework 3.5, 4.0, 4.5 and still get the same error. I'm attaching the test project that I have been working with.

Is there anyone out there that can help, or has at least seen this issue before?

Howard

Attachments

Outcomes