WAB redirect_uri error 400 ...again

3542
14
Jump to solution
10-27-2015 04:42 AM
FriedrichStriewski1
New Contributor III

I followed the instructions and tryed problem solving with Rebeccas tips but still no success with running the Web Application Builder v.1.2.

Machine is a personal computer, Win 7, browser Firefox or Chrome. My account is a free ArcGIS Dev. account.

Usually I work with the Story Map application and use XAMPP to test my stuff, The instruction is clear to register with the (full) computer name, say: "uxxxxxx". No Domain but Workgroup "WORKGROUP". Redirection URIs would be:

In AGOL: My Content/ Add Item / An Application / URL:

http://uxxxxxx:3344/webappbuilder/

Redirect URI:

http://uxxxxxx and https:uxxxxxx

Portal URI:

http://x3lt.maps.arcgis.com/

Still getting the 400 when suppling the client ID ... what am I doing wrong? Tried with both browsers, deleting the signininfo.json, reinstalling WAB. Are the URIs correct? Can I use WAB with the free / trial dev account?

Any help on this topic is much appreciated!

0 Kudos
1 Solution

Accepted Solutions
FriedrichStriewski1
New Contributor III

Ok, I finally found the mistake - its so embarrassing...

Turns out I misspelled the intended computer name when I was setting up my machine years ago. Never noticed, not even when I checked the name twice before working with WAB. Spelled it correctly like a hundred times when setting up the URIs but with a misspelled computer name no wonder it didn't work out.

So yeah. Add hint #X: Double check your computer name and pay close intention to spelling.

Unbelivable. Don't tell anyone and so sorry to have bothered you with such a dumb mistake.

View solution in original post

0 Kudos
14 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Friedrich,

   Your redirect urls should include the port number and /webappbuilder:

http://gislap183:3344/webappbuilder, https://gislap183:3344/webappbuilder

0 Kudos
FriedrichStriewski1
New Contributor III

Hey Robert,

thanks for your reply!

It doesn't say so in the instruction, part "provide App ID for Web AppBuilder, step 4. (Get started—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers ). Tried it anyway but sadly it is not solving the issue. Error is the same.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Friedrich,

You must be overlooking it.

Provide App ID for Web AppBuilder section # 2 b says:

For URL, enter http://[yourmachinename]:3344/webappbuilder.

So can you provide me any more info on what is the issue you are seeing? Is WAB just hanging on the loading screen?

0 Kudos
FriedrichStriewski1
New Contributor III

Robert,

I added the application in AGOL (My Content/ Add Item / An Application / URL)

as specified above (see my first post). It is not possible to skip this step or to leave the url field empty.

WAB is loading in the browser, I am redirected to http://u-----:3344/webappbuilder/?action=setportalurl , asked for Portal / Organization URL, which is http://x3lt.maps.arcgis.com/ (free dev account) and when I provide the client ID as shown in AGOL the error pops up.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Friedrich,

   Have you seen the FAQ about "What should I do when I try to set the App ID and encounter an Invalid redirect_uri error?"

FAQs—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

0 Kudos
FriedrichStriewski1
New Contributor III

Robert,

yes it basically says delete "signininfo.json", correct URIs and start again. Did that several times.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Friedrich, if I'm reading the above correctly, you are creating the AppID in AGOL, then using your Portal to register when you start up WAB for the first time?  The AppID should probably be setup on Portal too.  When you first start up WAB and it asks for your Portal, it needs the AppID at that location. 

I don't use Portal myself, but you should be able to follow the same instructions for My Content/ Add Item / An Application / URL in your Portal and try again with the Portal and the appID from Portal.

Hope this helps.

0 Kudos
FriedrichStriewski1
New Contributor III

Rebecca,

Ah sorry, that was misleading. No I don't use" Portal", I create the app in AGOL and use the App-ID provided there.

Login to AGOL is with the free dev account.

0 Kudos
FriedrichStriewski1
New Contributor III

My settings in AGOL/WAB-app panel (german language settings)

WAB.jpg

0 Kudos