WAB 2.4 unable to complete operations when changing icon for widget

453
2
06-13-2017 03:47 AM
Nicole_Ueberschär
Esri Regular Contributor

I am trying to change the icon of my info widget. I donwloaded the original icon as png, changed it as desired and tried to update it in my widget. When I use the png format I can upload it but when I try to save it, I always get the message "unable to complete operations". Uploading a gif worked well but I think a png would look a bit smoother and would match better the original icons. Any idea what causes this issue? The hint for changing the icon says, png, gif and jpg are allowed file formats. 

Thanks in advance!

0 Kudos
2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Nicole,

   What widget and can you provide the .png you are attempting to use?

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

Hi Robert, thanks for looking into this. 

I tried to change the icon for the "About" Widget from the "i" to a "?" icon. When I just tried to change it back to the original (png) icon, it worked, so it seems to be a problem with my file:  icon faq. Unfortunately you can't see it because it's white on transparent background, but it's there

Edit: Just tried again with different saving options: I did not check the option for interlaced this time and now I could upload the picture. (sorry, in German ;-))

Thanks anyway...