Swipe Plus Widget Version 1.1.3 April 11, 2015

8060
10
04-05-2015 07:30 PM
Labels (1)

Swipe Plus Widget Version 1.1.3 April 11, 2015

2/18/2017 - update download linke

This widget is an enhancement of the Esri Swipe Widget.

Live Preview Site

Bug Fixes in Version 1.1.3

  1. Fixed the _WidgetMetadataMixin so it would work with FireFox and IE as well as Chrome.
  2. Updated the Live Preview Site.

Enhancements and Changes in Version 1.1.2

  1. Added the _WidgetMetadataMixin to the widget.  Allows you to Alt-Click the widget header and see the version information.

Enhancements and Changes in Version 1.1.1

  1. Changed the z-index of the widget so it would not be under other widgets (e.g. Coordinate Widget) on a smart phone.
  2. Added a Close Button to the layer menu so it can be closed on a touch device.
  3. Modified the behavior of the widget icon for touch devices so you can open the layer menu.  If the widget is open and the layer menu is closed, tapping the icon will open the layer menu.  If the widget and the layer menu are both open, tapping the widget icon closes the widget.

Features:

  1. All three styles are available (Vertical, Horizontal, and Spotlight.
  2. Multiple layers can be selected to swipe.
  3. Three sizes of Spotlight to choose from.
  4. Cursor reverts to default cursor when in the Spotlight to indicate popups are available. (You can still move the Spotlight from within.)
  5. Position of the Vertical and Horizontal swipe bars and the Spotlight are remembered (within the current browser session).

Download:

SwipePlus-1.1.3-2015-4-11.zip

https://community.esri.com/docs/DOC-9626-swipeplus-113-2015-4-11zip 

Larrys Custom WAB Widgets and More

Labels (1)
Comments

Larry,

It could be just me but the link to download does not work.

Thanks!

Rickey,

It's not just you.  My mistake.  It's fixed now.

Larry

Does the advanced swipe widget have the ability to handle grouped feature service layers?

Hello!

I was trying to use this widget, but for some reason it is not acting as a button. I'm not sure what I might be doing wrong. I added the image below to show what I mean because its a little hard to explain - its added as a regular non-button widget & when I select it, it opens the button.

swipePluse.PNG

In my config file in the widgetOnScreen.widgets array I have this:

{

  "uri": "widgets/SwipePlus/Widget",
  "position": {

        "left": 7,
        "top": 145,
        "relativeTo": "map"
   },
  "version": "1.1.3",
  "name": "SwipePlus",
  "label": "Swipe Plus",
  "closeable": true,
  "config": "configs/SwipePlus/config_Swipe Plus.json"
},

I didn't notice anything that seemed odd, I'm assuming there is something small I'm not considering. Can anybody help?

Thanks,

Jamie

Jamie,

   Here is how to add it to the config.json:

{

        "uri": "widgets/SwipePlus/Widget",

        "position": {

          "left": 7,

          "top": 145,

          "relativeTo": "map"

         },

        "version": "1.3",

        "id": "widgets_SwipePlus_Widget_11",

        "name": "SwipePlus",

        "label": "Swipe Plus"

      },

Thanks! Works now!

I was trying to figure out where my issue was after comparing my config with your config. Once I removed the "closable" attribute, it was acting as I anticipated. I had created the config with the builder (instead of just manually adding it), and that property was added to it. After minor digging, I didn't see this attribute relating to the SwipePlus widget, but relating to the AttributeTable widget. If you have any info or ideas about this I'd would love to hear Thanks again!

Is anyone using this widget in version 2.0?  Initial testing suggests no.  Thanks.

Original developer no longer has time to support this widget so it is dead in the water.

Thanks Robert.  I saw a post of yours in reference to app creation errors.  And the solution you recommended was to install another copy of web appbuilder.

With that in mind, can I just install 1.3 and utilize this widget?  Just curious, as this is great widget.

Thomas,

App creation errors were fixed in 2.1 but the work around in 1.3 and 2.0 are to just keep on clicking the OK buttons until the app is finally created (be patient it is more then a couple of times). You can have as many different versions of WAB installed as you want, so yes.

Version history
Revision #:
1 of 1
Last update:
‎04-05-2015 07:30 PM
Updated by:
 
Contributors