Identify Widget Version 2.17 - 1/20/2021

199558
471
02-23-2015 05:20 PM
Labels (1)

Identify Widget Version 2.17 - 1/20/2021

Live Preview Site

Web AppBuilder for ArcGIS | Help - Identify Widget

 

List of the latest enhancements and changes:

  1. Fixed an issue when there are no configured layer in the widget.

 

Previous enhancements and changes:

  Check the "Older enhancements or changes.txt" in the download for a complete list.

 

Older Versions

Last 2.4 version

Last 2.5 version

Last 2.7 version 

Last 2.8 version 

Last 2.9 version 

Last 2.10 version

Last 2.11 version

Last 2.12 version

Last 2.13 version

Last 2.14 version

Last 2.15 version

 

ATTENTION:

  1. If you are hosting this widget on a https server, then make sure you change all your excludelayer urls to https. Failure to do so will result in widget failure.

 

Features:

  • Specify which layers are to be identified
  • Format the fields for identify layers
  • Configure links and link icon
  • Close result popups after a number of seconds of losing focus
  • Choose which layer to identify in the widget UI using drop down list
  • Specify layers to be excluded from identify operation
  • Choose to only identify configured layers
  • Replace null values with empty strings
  • Configure default symbology for identify results
  • Specify Visible, Top, or All layers to be identified.
  • Option to Keep Identify Active
  • All Identify geometry types are configurable
  • Option to use map time
Labels (1)
Attachments
Comments

@MattiasEkström 

No that is not how it should be working and I will have to patch that issue. I have already worked through the issue based on what info you provided. The immediate workaround for you would be to have at least one layer configured in the widget.

That workaround doesn't work. In fact it's when I have one or more configured layers I get that error message. And I actually get a result in the map. One feature from one layer (one that's is not configured, but comes from the web map) is higlighted in the map.

When I have no configured layers at all, I don't get that error message, and that one feature isn't found either.

@MattiasEkström 

Try the 2.17 version just released.

Does the 2.17 version work with WAB 2.16? I'm at version 2.16 since that's the latest version in portal.

When adding the widget, the settings-window doesn't show anything else than the loading animation. And it is just stuck there. But I can click OK and then actually use the widget, it seems to be working accorrding to default settings. But I want to be able to change the settings. I don't get any errors in the console. And it's the same when I try to edit the settings.

Any ideas?

Hello @RobertScheitlin__GISP,

first of all thank you for your efforts and this cool widget.

I'm using current version of Web App Builder and the latest version of your widget, released a few minutes ago.

My app will be called with a webmap id as url parameter, so I don't know all map layers for identify at configuration time. I don't add additional layers "Add identify layer", "only those" is deactivated. Now I expect the widget to read my map layers and offer them as well as "All Layers" option but the drop down remains empty.

I have a basemap (WMTS), Feature Layer and an Image Layer (Image Service) in my map. I can click the feature layer and I get an entry in "Results" tab. If I click Image Layer I don't get a result. If I look into browser request tab I see an identify task on my basemap and a query request on my feature layer but no identify on the Image Service.

Can you help please?

@MattiasEkström 

Compatibility I an not sure about that. But I would not expect any issues. Are there any errors in the browser console when you attempt to open the settings?

@RichardReinicke 

That is not how this widget is developed to work. At runtime the only thing that will display in the "Identify From" drop down are layers that have been configured with the Add Identify Layer button in the widgets settings.

@RobertScheitlin__GISP 

It works fine today, I don't know if I missed clearing cache or if a restart of WAB Dev was needed or something like that. Thank you very much for your help!

@MattiasEkström 

Glad it is working for you now.

Hi @RobertScheitlin__GISP ,

I am running into an issue where none of my company's service layers can be added to the the Identify URL. I am using Identifier widget version 2.17 and services are hosted on Enterprise 10.6. Looking through previous comments, I could not find a similar issue. Do you have any troubleshooting advice?

Thanks,

 

 

@ForrestBlack it might be because you pulled in a map server instead of a feature server, try going down one more level in the rest url and then trying again. 

@VanessaSimps , that is as far in as I can go.

This also matches the URL format Robert documents in his help guide.

 

 

 

@ForrestBlack It looks like you are trying to use this on a raster (or at least that is what it looks like from the url string)?  This tool might only be for vector data. have you tested it on another feature?

@VanessaSimps I have seen examples of others using this tool on raster data. It returns the pixel data in a pop-up. Regardless, the tool does not work with any of my vector data either.

 

 

@ForrestBlack 

The issue is if the web map is using httpthen when you configure the layer in the identify widget you have to use the same protocol (i.e. https not http).

@RobertScheitlin__GISP 

My webmap is https and that is what I am copying in as the identify URL. Do I need to go into the code somewhere and change the protocol?

Forest,

   OK, I thought I saw in your screenshots that you where mixing protocols.

What I am now seeing is that there is a DNS look issue with your url of

https://blah-blah.com/server/rest/services

 

 

I made certain to change all my exclude layer urls to https in the widget. Do I need to change some of my service configurations?

@ForrestBlack 

As long as the urls that you configure in the widget are identical (CaSe and protocol) to the layers in your webmap, then there should be no issue.

From some of your screenshots it looked like you could not get the widget to accept your layer url. So I tried the layer url for the generators map service  of yours and got a DNS lookup error from 

https://blah-blah.com/server/rest/services 

So are you or are you not seeing the same on your end?.. 

@RobertScheitlin__GISP, I am not seeing a DNS lookup error on my end, but this may be due to our Enterprise security configs. I will just try to troubleshoot it. Thanks for your help. By the way, would you please delete the URL references in your comments? It occurred to me that I may not want to expose them online for anyone to see.

 

Thanks for your help.

Will do.

Version history
Revision #:
3 of 3
Last update:
‎01-20-2021 06:34 AM
Updated by: