Enhanced Search Widget Version 2.21.1 - 11/16/21

07-14-2014 03:57 PM
Labels (1)

Enhanced Search Widget Version 2.21.1 - 11/16/21

Live Preview Site

Web AppBuilder for ArcGIS | Help - Enhanced Search widget


List of the latest enhancements and changes:

  1. Added Max rows of 10 to all the widgets dropdowns.


Older enhancements or changes

Check the "Older enhancements or changes.txt" in the download for a complete list.


Older Versions

Last 2.17 version

Last 2.13 version

Last 2.12 version

Last 2.11 version

Last 2.9 version

Last 2.7 version

Last 2.6 version

Last 2.5 version

Labels (1)


  I have seen before where a ArcGIS Server update has made changes to field names of services (without the users knowledge).


I have compared the names of the fields to an archived version and they all still match. I should mention  that this is not an app or dataset specific problem. All of our web apps have experienced this issue with all of their configured eSearch layers. The issue seems to originate in the App, as the query that is sent out is no longer correctly constructing. The OTB search bar is still functioning correctly. I have attempted to build test applications in WAB 2.5 and 2.4, using fresh services and the issue persists.

Hi Eric - is there a reason you are using eSearch 2.3 version with WAB 2.4x?

sorry, that should have read eSearch 2.4 with WAB 2.4


   I have never seen a widget just start behaving differently  (i.e. the sql query change) just because of a ArcGIS Server update. I am not sure what to tell you. You said you tried WAB 2.5 and go the same result?.. That is even stranger. Can you start a new thread on this and post your config_eSearch.json?


Thanks for looking into this Robert.


Thank you for the updates you have made!  This continues to be an extremely useful widget.  I have been looking forward to working with related tables with the widget.  When I add a related, I can add the fields I want but do not see an area to enter a search expression.  I am using WAB Developers Edition 2.4.  Could that be the issue?  I've attached a screenshot.




   Sorry your are reading more into the Relate support then there is. There is no ability to query related data. There is only the ability to display data that is related to the selected search result.


Thank you for clarifying this.  And thanks again for the widget and recent updates.



Thanks to update this widget, this is really a nice widget. I was trying to add the date field column in my search layer. I was surprised in the query section where we "Add Expression Value" the date field does not have "in the last" option. How to add this parameter in the widget? 


  that is what "Start date is current date minus x day(s)" on your screen shot is talking about.


I tied but it don't give an option like the screen shot so that the end user can just drop down the by minute, hours,days, weeks, months, years.


Irfan Afsar


   You are comparing my widget with the Query widget. They are both different and have different capabilities and UI's.

Hey Robert,

Your widget looks like a great thing, unfortunately I cannot get it to work with my related tables.  When I add the URL for a search layer, the attributes available are good.  However, when I go to add the related table information, the related table is available for me to select.  Once selected, the attributes that are available to select from are the exact same as the main query layer, not those of the related table.

Another thing that keeps happening when setting up the related table information, the configuration popup window never shows up, yet I notice blank entries in the little window.  I can access the edit links to delete each entry.  I have to save the configuration, then enter back into it in order to get the related table configuration to open.

Any ideas/thoughts as to what I may be doing wrong?  I have the latest Web Appbuilder version, using ArcServer 10.4.1, portal 10.4.1.


   Did you download the latest 2.4 version of the widget or are you mistakenly trying to use the 2.5 version of the widget?

Ah ha! Most likely. I’ll try things out with the 2.4 version.


Jayson Lindahl

Can we not use the 2.5 version at this time?


Jayson Lindahl

I just downloaded the 2.4 version and I'm seeing the same thing.  Does it matter if my map service is a feature service or regular map service?


  you are using Portal 10.4.1 so that means the version of WAB that is native to that portal version is 2.1. You would have to be using Portal 10.5.1 just to be at version 2.3 of WAB. If you want to be current on WAB Versions then you can use WAB Developer to deploy you apps to your own web server.

Come to think of it custom widgets like the eSearch were not even supported in Portal until 10.5.1.....

That is correct.  I'm sorry, I meant to say that I am using WAB Deeloper 2.5 for this, but consuming 10.4.1 map services.


   So in that case you should not be having any issue with using the 2.5 version of eSearch in WAB 2.5 then. Are you sure you have updated the eSearch widget to 2.5 in your stemApp widgets folder and any apps widgets folder that is using eSearch?

I just downloaded and moved the latest into the stemapp\widgets directory.  This is the only application that is using this.  I have tried in both IE 11 and Chrome.  Do I need to update any other settings/configs to get it to work?

No, you don't have to do anything else. So have you saved an app with the eSearch added yet?

Yes I have.  I went ahead and turned off the compatibility settings in IE as well as restart the machine I was working on.  In the saved app, when I open the tool, all I get are the task and results tab, neither of them activated.  I then activate the task tab and try running a search.  It results in a hung IE session and I have to close it out.  In the past I've gotten it to work (setting it up with incorrect related data), now I can't get it to run all the way through.


   My eSearch widget does not have a Tasks and Result tab. You are using the OTB Query widget if those are the tabs you are seeing.

Sorry. This is what I have when I try running the widget. This opens as default, even though none of the tabs have been selected for removal.


Jayson Lindahl


   sorry I am still a little confused. As I mention in my last reply my custom eSearch widget does not have tabs label "Tasks" or "Result" (mine says "Results")  but the OTB "Query" widget does have these exact tabs. So now the question remains is are you possibly confused on which widget you are using?

Sorry about that. I had pasted an image in my email reply, must not have gone through. I am using your widget. When I launch the widget, “By Shape” and “Results” are displayed, neither one active (even though nothing has been checked in the configuration as not to show).


Jayson Lindahl


   So the eSearch widget is developed to know if you did not configure any search expressions or check that the layer is a "Spatial Search Layer" then there is no need for those tabs to be displayed in the widget as they would be useless. You need to configure some search expressions for your layers and check the "Spatial Search Layer" if you wan to see those tabs.

Hi Robert,

Thanks for these widgets!  Question - I upgraded WAB to 2.5 and upgraded my eSearch and eBasemap to 2.5 as well, replaced the widgets in the client\stemapp\widgets folder, and was able to upgrade all my apps.  When I open them in WAB 2.5 however it doesn't appear they have upgraded, I see nothing for relates in the eSearch and when I inspect them (alt+click) it tells me they are still 2.4.  Am I missing a step with upgrading them?  The widgets VersionManager.js shows they are the newest version in the folder.  Thanks!

Kim Graham


  For existing apps that you upgraded you will have to replace the individual apps eSearch folder in the apps widgets folder.

DUH, that makes so much sense now, thank you!  If anyone else has the same question - you can copy/paste the config.json file for the widgets into the upgraded widget folder to keep your settings.

Thanks again.

I'm sure your already working on it, but looks like the 2.5 widget won't work in 2.6 that came out today (Least not in tab theme)

I will be working on 2.6 version real soon.

Is it possible to pass in multiple values in an eSearch URL?

I would like to be able to pass multiple parcel numbers through a URL and have them displayed on my map as eSearch results.

I see in the help that it should be possible:

  • The esearch parameter can have more than one search text/number/date if they are separated by a pipe character "|". Here is an example ?esearch=SPECIAL|WATERFRONT&slayer=1&exprnum=0

I am able to get the URL search to work with one parcel number, but when I put in the pipe character and add the next parcel number it doesn't select anything.


   Sorry for the confusion. What that means is that a search layer can be configured with more than one input parameter and a pipe delimited  esearch param will feed the first value to the first input and the second value to the second input in the widgets UI.

for example:


Hi Robert,

I am using web app builder 2.5 with latest eSearch 2.5 widget (8/10). Great tool. Thank you!

I would like to ask if possible to add 2 improvements:

- ability to rename the search results

- ability to create more than one search result by avoiding overwriting.

Thank you.

Lacri Ursu

Hi Robert,

Your widget is really a good addition to my current app, I have one request if it is possible to add "in the last date"  by minute, hours,days, weeks, months, years. Is there any way to add that functionality in the widget, please point me to that. I will really appreciate your favor. 

Hello Robert, any thoughts on the alignment issue with links and the layer symbol as seen below?

eSearch search results symbol overlaps links


   I don't have any plans to add that functionality right now but I will consider it for a future release.


 The ability to have multiple eSearch results in the map at the same time is a major change to the widget and is not currently under consideration. I will consider the ability to rename search results.

Perfect, thx!

Thank you, Robert. Having the widget as is, is excellent for users, performing the spatial search is what makes it even more than perfect!

Renaming the results will be a great improvement; when a map is printed, users can easily understand their search results.

Hi Robert!

As usual thank you for all your great work, as most of us moving out from flex into WAB, I started playing with the widgets to understand more about them, my question is:

I changed the label searchLayer: "Search Layer", to searchLayer: "Search By", in the string.js file in side your widget but makes no effect in the final website.

if you have time could let me know where I should change the label, we are querying only one layer - multiple fields and reads much better "Search By" instead of Search Layer.



   The string.js file is the appropriate loaction. Are you changing it in the stemApp/widgets folder our your actual apps widgets folder?

Robert. Indeed I was changing the correct file at the wrong location, all set now, thank you! Still learning. Daniel

Hi Robert Scheitlin, GISP‌, this widget does exactly what we're looking for, except for one feature - multi-select.

More specifically, I am looking to modify the widget such that when searching by value, instead of just selecting one item from an expression drop-down, multiple values can be selected, where the values are dynamically created with the 'Unique' radio toggle.  While the 'Value' radio toggle allows for searching multiple values by typing in a where IN statement such as 'R1,R2', it does not provide the user with a list of valid choices.  Our old widget handled this via multi-select check boxes:

Do you have any tips on where to begin making such changes?




   I had looked into this before. The issue is to find a Javascript control that allows for multi select and then integrate it into the widgets UI. The settings UI for choosing when to add the multi select is one task and then the part of taking the selections from the control and converting that to a proper IN SQL statement is another task. Basically I have not invested the time into this as there is a very small number of people interested in this ability.

Thanks for your reply, Robert.  I'll look into how feasible this approach is.  I'll be sure to post my changes if I go this route.



Version history
Revision #:
7 of 7
Last update:
‎11-16-2021 06:12 AM
Updated by: