Rotate Valves to match connecting line

2645
21
Jump to solution
12-12-2016 05:04 PM
TimHayes1
Occasional Contributor III

I have a point feature class (isolation valves). I am using ArcGIS 10.2.2.

Each valve is on a line (pipe). The line is split at the valve. 

I want to rotate the valves to match the orientation of the connecting line. 

When I tried using the rotation tools in the Water Utility Network Editor Toolbar it does not rotate the valves. The older version from years ago was able to do this. But, the issue seems to be due to the fact that the line is split at the valve. 

Any ideas on how to get the points to match the orientation of the line?

Tags (1)
0 Kudos
21 Replies
RobBlash
Regular Contributor

Mike,

This does not work (my parameters are G|0|Diameter|wMain). Also when I try the "Rotate Selected Junctions" button on the Water Utility Network Editing toolbar I get the same results (0 rotation when the intersecting lines are split, or expected behavior when they're not split. Also my data is in a geometric network.

Thanks,

Rob

0 Kudos
MikeMillerGIS
Esri Regular Contributor

I cannot repo your issue with geometric data.  Have you tried it with a empty value info?

0 Kudos
RobBlash
Regular Contributor

Yes, with the same results. I can send you some data or do a gotomeeting session to show you what's happening on my end. FWIW this is happening in several GDBs for different projects I'm workign on, so I don't think it's a data issue.

0 Kudos
MikeMillerGIS
Esri Regular Contributor

Robert,

Could you post the attribute assistant log file?

0 Kudos
TimHayes1
Occasional Contributor III

Can you walk me through this or point me to a source that can help? how do I add it to the rule? and where would insert that tidbit of code you suggest?

0 Kudos
MikeMillerGIS
Esri Regular Contributor

That is the value info I posted, just add it there.

TimHayes1
Occasional Contributor III

Sorry to be pesky, but add it where? the config file?

0 Kudos
RobBlash
Regular Contributor

Tim,

Those extra parameters would go in the ValueInfo field of the DynamicValue table, see screen shot attached.

View solution in original post

TimHayes1
Occasional Contributor III

Before I dive further into this, do I need to be using a Geometric Network or can this be done without a Geometric Network?

0 Kudos
TimHayes1
Occasional Contributor III

Nevermind, I found it: Set up configuration tables - Attribute Assistant | ArcGIS Solutions 

I need to really get familiar with Attribute Assistant. Thanks.