Attribute Assistant-Dynamic Value Table-TableName Values Expressions

111
2
08-12-2019 07:36 AM
Labels (2)
Highlighted
New Contributor II

I am having a problem populating an ID attribute "GISOBJID" which is a string in a versioned SDE data set. The AUTONUMBER I want to combine "ASSETNUM" works fine for everything , but I want to combine that with an ALPHA prefix (FM-123) into the "GISOBJID" attribute. I have tried several ways and no success. Only the AUTONUMBER works. I have tried using the full SDE name "UTILITIES2.CCU.ssPressurizedMain" in the DynamicValue Table and the shortened version "ssPressurizedMain" with no results. I have also tried an EXPRESSION "FM-" & Str( [ASSETNUM] ) and GenerateID with SSPRESSURIZEDMAIN|0|FM-[seq] still no success. Any help with this would be greatly appreciated. Thanks in advance!

1. DynamicValue-GENERATEID long layer name

2. Generate ID Table Long layer name

3. Dynamic Value Short layer name

Tags (1)
Reply
0 Kudos
2 Replies
Highlighted
Occasional Contributor

I know this is possible using GENERATEID, because I did the EXACT same thing you are trying to do.... but I'm using a SQL SP for my asset id assignment now, so I don't have the method in my dynamic value table anymore!  Let me try to rack my brain.  The field type of your GISOBJID field is text right?

Reply
0 Kudos
Highlighted
New Contributor II

Thanks for the reply Cort. Yes the GISOBJID is a text value. Neither of the DynamicValue or GenerateID tables are versioned and they reside in the SDE dataset. I've been racking my brain trying combinations with no success.

Reply
0 Kudos