'Object reference not set to an instance of an object' in Arc Hydro Tools. What to do?

8716
2
Jump to solution
09-17-2014 05:56 AM
StefanieSteinbach
New Contributor III

Hi all,

I have been working with Arc Hydro Tools to perfom catchment analysis for a while now.

A few days ago, I encountered a new problem: The error warning 'Object reference not set to an instance of an object' after trying to compute drainage lines. In fact, all raster datasets produced by the Arc Hydro Tools before that step were without spatial reference. I tried Define Projection, but as soon as I click on the raster again it tells me the spatial reference is unknown. Even weirder is that after Project Raster and creating a completely new raster with an intact coordinate system, the same error would occur when trying to create drainage lines based on the projected rasters.

The next morning, everything worked fine again. Unfortunately, now I am getting the same error again and I'm running out of ideas. I cleaned my temporary files folder, set a spatial reference to the whole project, started a new project from scratch, restarted ArcMap and my Laptop various times..

Has anyone else run into this problem before? Or even found a solution? Any help would be greatly appreciated!

0 Kudos
1 Solution

Accepted Solutions
StefanieSteinbach
New Contributor III

Thanks a million for your answer, who would have thought it could be so easy? My problem was resolved by putting all layers into my geodatabase.

View solution in original post

0 Kudos
2 Replies
MarkBoucher
Regular Contributor II
StefanieSteinbach
New Contributor III

Thanks a million for your answer, who would have thought it could be so easy? My problem was resolved by putting all layers into my geodatabase.

View solution in original post

0 Kudos