DEM reconditioning: zeros become "No Data"

480
7
02-27-2019 06:00 AM
AlexanderVentura
New Contributor II

Hi all,

I am using the "DEM reconditioning from stream grid" tool and unfortunately it seems that all my pixels where the value is "0" (zero) are transformed to "No Data" points.

In my original DEM file (GRID format) values range from 107,97 to -1,77.

Does anyone have any idea what the problem may be? 

Thanks a lot for the help.

Alex.

0 Kudos
7 Replies
ChristineDartiguenave
Esri Contributor

Which version of Arc Hydro are you using? I believe this is something we have fixed. Internally, when we use the Con_sa tool, 0 is seen as no data unless we put an additional condition.

Christine Dartiguenave

Esri Water Resources Team

eliasrex1
New Contributor II

I am also running into this same issue. I am using ArcMap 10.6.1. However, it does not seem to just change 0 values to No data, but also values less than 0. I am not sure if I am doing something wrong or if its a problem with the version of Archydro I am using. I would appreciate any suggestions. 

0 Kudos
ChristineDartiguenave
Esri Contributor

Have you installed the patch for Spatial Analyst (ArcGIS (Desktop, Engine, Server) 10.6.1 Spatial Analyst Patch ). I just tested with a GRID with 0 and negative values and could not reproduce the issue with the latest version of Arc Hydro (/ARCHYDRO/ArcHydro/Setup/10.6/10.6.0.81/ ). If you still have the issue with this version and the patch installed, I may need to take a look at your data.

Christine Dartiguenave

Esri Water Resources Team

0 Kudos
eliasrex1
New Contributor II

I Just installed that patch and tried it again. I still have the same problem. How could I share my DEM with you?

0 Kudos
eliasrex1
New Contributor II

I also have the stream features I would need to share. 

0 Kudos
eliasrex1
New Contributor II

Here is what my raw DEM looks like, it contains negative and 0 values.This is what the DEM looks like after reconditioning it with Archydro. 0 values become NoData.

0 Kudos
ChristineDartiguenave
Esri Contributor

elias rex

I just messaged you with an upload location.

Christine

0 Kudos