ArcHydro10 Drainage line processing error! Please please help!!!

10-22-2011 03:48 AM
Labels (1)
New Contributor

I am running Windows XP Professional with Service Pack 3 (Pentium Dual-Core CPU, 3.07 GHz, 1.96 GB RAM). I have ArcGIS 10. I have installed the ArcGIS 10 Service Pack 3 (

I installed what I thought was the latest version of ArcHydro 10 version 2.01.133 from here:

I am delineating watersheds from 30m ASTER DEMs. I go through the standard pre-processing steps (Fill Sinks, Flow Direction, Flow Accumulation, Stream Definition, Stream Segmentation, Catchment Grid Delineation, Catchment Polygon Processing). Then I get to Drainage Line Processing and I get the following error:

Error HRESULT E_fail has been returned from a call to a COM component.

I tried uninstalling ArcHydro and then installing HEC-GeoHMS 10.0 ( which automatically installs ArcHydro10 version When I go through the same process, I get the same error.

This does not happen when I run this on Windows 7 machine (Intel Core i5, 2.53 GHz, 4GB Ram, 64-bit OS).

I am mainly a user and not so much a developer...

Please help!!!

Thank you,
Tags (2)
0 Kudos
1 Reply
MVP Frequent Contributor

You've got some answers in this thread.

0 Kudos