Empty Field in Attribute Table, but Data Exists

888
2
01-18-2019 09:22 AM
KevinNewbury
New Contributor II

I ran into a problem building a webmap in Web Appbuilder, where a field is not showing as populated in the Attribute Table widget. The same field shows populated in the popup, as well as in the data table of the Feature Layer.

Here is a screen snip of the issue: on the popup Council District shows as "3", but in the attribute table it is blank.

Also possibly relevant is this field has a Domain associated with it with options from 1 to 10. I have tried refreshing the page, ctrl+f5, the refresh button on the widget, clearing my browser cache, logging out and back in, and even overwriting the service from my ArcGIS Pro project file with no changes. My Enterprise admin tells me he hasn't run into this before and that it sounds like a bug. It is a hosted feature on AGOL, not a webservice. Also, there are other fields with domains in the app, Type of Project and Level, which are displaying properly in both.

Thank you for your time.

0 Kudos
2 Replies
GillianElliott
Esri Contributor

Check that you don't have Minimum/Maximum Values set in your layer's settings.

Go to the feature layer's item details page in ArcGIS Online > click the Data tab > Click Fields (top right) > Council District. If there is a min/max value set, delete it, and the field should now appear in your web app. 

HannahStaples
New Contributor II

Hi Gillian, I am experiencing the same error but with coded domains. Is there anything I can try to resolve this?