Spatial statistics tools not working

05-08-2011 06:32 PM
New Contributor
I'm running ArcGIS 9.3.1 w/ service pack 2  on Windows 7 64 bit home edition.  When I try to run the tools in the Spatial Statistics toolbox, I get an error message. I've tried uninstalling and re-installing the software, with a cleanup in-between,  and get the same error.

A different thread on here had instructions for capturing the process log.  Here's the log for running the nearest neighbor analysis, which errored out:

<ResultView Tool="Average Nearest Neighbor">
<CommandLine>AverageNearestNeighbor_stats la_zip_emp 'Euclidean Distance' true 10000</CommandLine>
<ToolSource>C:\Program Files (x86)\ArcGIS\ArcToolbox\Toolboxes\Spatial Statistics Tools.tbx\Analyzing Patterns\AverageNearestNeighbor</ToolSource>
<StartTime>Sun May 08 18:38:09 2011</StartTime>
<Parameter Label="Input Feature Class" Type="Layer">la_zip_emp</Parameter>
<Parameter Label="Distance Method" Type="Scalar">Euclidean Distance</Parameter>
<Parameter Label="Display Output Graphically" Type="Scalar">true</Parameter>
<Parameter Label="Area" Type="Scalar">10000</Parameter>
<Parameter Label="NNRatio" Type="Scalar">0</Parameter>
<Parameter Label="NNZScore" Type="Scalar">0</Parameter>
<Parameter Label="PValue" Type="Scalar">0</Parameter>
<Layer Name="la_zip_emp">C:\Users\PaddleGirl\Desktop\grad school\Geo526\Lab 4\LAemploy_updated\la_zip_emp.shp</Layer>
<Error><type 'exceptions.AttributeError'>: Object: Tool or environment <OutputCoordinateSystem> not found</Error>
<Error>Failed to execute (AverageNearestNeighbor).</Error>
<EndTime>Sun May 08 18:38:17 2011</EndTime>
<ElapsedTime>8.00 seconds</ElapsedTime>

Any help would be appreciated.
0 Kudos
5 Replies
MVP Esteemed Contributor
Is there a chance that you aren't using a projected file as input? The error line contains .... OutputCoordinateSystem not found suggesting that either your data are in decimal degrees and/or doesn't have a defined coordinate system
0 Kudos
New Contributor
hi Dan,
Thanks for your answer.  My data is projected (NAD_1983_StatePlane_California_V_FIPS_0405_Feet) and the data and tool both  work on another computer (running Windows 7 on 32 bit). The problem has to be a setting on my laptop, how Arc installed on my laptop, or maybe a compatibility  issue w/ ArcEd 9.3.1 and my laptop (windows 7 64 bit.....)??  Several people have suggested something with Python, but I don't know where to start with that.  Any help would be appreciated!

0 Kudos
MVP Esteemed Contributor
  Several people have suggested something with Python, but I don't know where to start with that.  Any help would be appreciated!

It does look like your script is not able to properly create a geoprocessor object. I think the best way to reconnect Python with ArcGIS is to uninstall *all* python related software from add/remove programs, then do a repair install of ArcGIS followed by reinstalling the most recent ArcGIS service packs.  This will ensure you have the right version of Python (2.5.1 32 bit) and that it can talk to ArcGIS.

Good luck!
0 Kudos
New Contributor
Thanks Curtis.  Uninstalled Python and ArcGIS, ran a disk cleanup, reinstalled both w/ a repair, installed service pack 2.....still no luck .  scratching my head on this one.... could this tool set (spatial statistics) be incompatible w/ 64bit???  the tools work fine on the desktop w/ 32bit architecture, but for a variety of reasons i need this work on my (much faster) laptop.

0 Kudos
MVP Esteemed Contributor
You said, installed both Python and ArcGIS -- the ArcGIS installer should install Python (and numpy) on its own. If you installed Python separately you will be missing numpy and that will make the geostat tools fail. Do other python scripts work??
0 Kudos