Model builder - avg. nearest neighbour report output location.

254
7
Jump to solution
04-24-2018 12:21 PM
ShaneStevenson
New Contributor

Hi all, in model builder I'm running the avg. nearest neighbour tool on a .shp file. Everything is working but is it possible to set the location that the html report saves to? Thanks.

0 Kudos
1 Solution

Accepted Solutions
DanPatterson_Retired
MVP Esteemed Contributor

Shane... the html report is supposed to be the parameter (ie a P )

The help topic provides the requirements for the report to appear in the Results and whether it will be listed in Catalog.

If you look at the script example, it requires a path for the report, once you have set it as a parameter.

They don't cover modelbuilder explicitly, but apparently, it should be able to be done

http://desktop.arcgis.com/en/arcmap/latest/tools/spatial-statistics-toolbox/average-nearest-neighbor...

View solution in original post

7 Replies
DanPatterson_Retired
MVP Esteemed Contributor
ShaneStevenson
New Contributor

Hi Dan

thanks for that. I've made Report File a model parameter but it still isn't obvious to me how to set the output location. I've gone through all the options. But none of them seem to relate to setting where the report is output to. Thanks.

 

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

if it is a file you want written, then it should be an output parameter...

(much easier to set these things up with script tools in a toolbox than a model in a toolbox though)

0 Kudos
ShaneStevenson
New Contributor

Hi Dan, yeah I agree it would be easier but I'm required to do it in Model Builder. I've Googled and found this (Creating model parameters—Help | ArcGIS for Desktop ) But I still don't see how to set a file-path as the location to save the file to. I've double clicked and right clicked on everything but see no option to do this.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

a file path is a workspace or a folder

0 Kudos
ShaneStevenson
New Contributor

I have created a model parameter called statistics. It is pointing to the folder I want the html report to go to. I have tried everything I can think of and have googled the issue. Is there a way to make the html report go to the statistics folder?

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

Shane... the html report is supposed to be the parameter (ie a P )

The help topic provides the requirements for the report to appear in the Results and whether it will be listed in Catalog.

If you look at the script example, it requires a path for the report, once you have set it as a parameter.

They don't cover modelbuilder explicitly, but apparently, it should be able to be done

http://desktop.arcgis.com/en/arcmap/latest/tools/spatial-statistics-toolbox/average-nearest-neighbor...

View solution in original post