Missing mean center statistics

422
1
03-25-2013 03:09 PM
jamiehiott
New Contributor
hello!
I just ran my mean center calculations, the input feature class was correct, the output feature class correct.
Calculations ran, I got a positive result in the corner of the map, but I CANNOT find it anywhere. Searched in the catalog, refreshed everything, ran it multiple times- still cannot find my statistics. Any ideas?
0 Kudos
1 Reply
LaurenScott
Occasional Contributor
Is it possible that some of the records in your dataset are missing geometry?
Try this:
Open a fresh, brand new ArcMap session.
Add your feature class to the TOC
Test 1:
Zoom to the layer ... if everything is good so far, zooming will not change what you see at all.  If suddenly your features are squished together very small, there is one or more features that are really far away from the majority of your features and you will want to try to locate those stinkers.  If the zoom test worked and nothing unexpected happened:
Test 2:
Using the interactive selection tool, select all of the features (just draw a selection box around all features). 
Then open the table for the feature class and see how many features it says are selected.  If everything is good so far, ALL of the features will be selected.  If the number selected is less than the number in the table, some of your features are missing geometry. Do a switch selection and either correct the geometry or remove those features from the feature class.
Still no clue about why the mean center is AWOL?
Test 3:
Run the Mean center tool.
Open the table to see the values for the X and Y coordinates... do they look reasonable?  If not:
** Use the Export Attributes to ASCII text file tool in the Spatial Stats toolbox, Utilities toolset.
** Check the X and Y coordinates for your features.  You should see the expected number of records and the X and Y coordinates should be reasonable.  If they aren't, you will need to correct or delete the problem features.

Test 4:
After running the Mean Center tool, Zoom to the mean center output layer... did you find the mean center now?

If none of this works, I don't know what's wrong... perhaps you can send your data to Tech Support to see if they can reproduce the problem.
Sorry you are having problems with the tool.
Best wishes!
Lauren
Esri
Geoprocessing and Analysis
0 Kudos