Error with M value tolerances

129
2
Jump to solution
04-18-2019 11:19 AM
Labels (1)
Highlighted
New Contributor

Hi all, 

I am new to Roads ans Highways and are working on initial set up. 

I have created an ALRS and are now trying to load a network from a feature class that I already have. 

I am receiving an error that states "The selected network units of measure does not match the M Tolerance of the existing feature class." 

I am working in the 10.5.1 platform and have let the ALRS create the appropriate tables and feature schema. 

I have a route feature class that is M and Z aware that I am trying to use to create the network. 

Any help or insight is appreciated. 

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Contributor

Hi Cameron,

I would encourage you to take a look at this topic that deals with tolerance and resolution settings in the LRS. http://desktop.arcgis.com/en/arcmap/latest/extensions/roads-and-highways/tolerance-and-resolution-se...

The error message you're getting points to the XY tolerance/resolution values not matching the expected M tolerance/resolution values.  Take a look at the XY tolerance/resolution, including the units, of the feature class you are trying to register as a network and verify the M tolerance/resolution is the correct conversion.

For example, if the XY tolerance was 0.1 feet and the resolution was 0.01 feet and you wanted to create a network in miles, your M tolerance would need to be 0.00001893939 (0.1 feet/5280) and the M resolution would be 0.000001893939.

Nathan @ Esri

View solution in original post

2 Replies
Highlighted
Esri Contributor

Hi Cameron,

I would encourage you to take a look at this topic that deals with tolerance and resolution settings in the LRS. http://desktop.arcgis.com/en/arcmap/latest/extensions/roads-and-highways/tolerance-and-resolution-se...

The error message you're getting points to the XY tolerance/resolution values not matching the expected M tolerance/resolution values.  Take a look at the XY tolerance/resolution, including the units, of the feature class you are trying to register as a network and verify the M tolerance/resolution is the correct conversion.

For example, if the XY tolerance was 0.1 feet and the resolution was 0.01 feet and you wanted to create a network in miles, your M tolerance would need to be 0.00001893939 (0.1 feet/5280) and the M resolution would be 0.000001893939.

Nathan @ Esri

View solution in original post

Highlighted
New Contributor

Hey Nathan,

Thank you for the documentation. 

I was able to use feature class to feature class and then adjust the environments to match those of the R&H document you sent me to! Then the Network was loaded right in after field mapping. 

Reply
0 Kudos