Identify Measures in ArcPro similar to ArcMap (where you can adjust the decimal places)

1083
8
Jump to solution
03-11-2021 09:44 AM
bbieb
by
Occasional Contributor

How do you adjust the decimal places for M values in the Identify tool in ArcPro?  We use the Identify Route Locations quite a bit in ArcMap and we are looking for the same/similar functionality in Pro.  Using the RH tools provided in Pro requires a RH license which is not realistic for all of our users.

I've been here but I think that is only for the actual measure tool (distance).

measure-decimals.png

 

measure-decimals-arcmap.png

measure-rh.png

brian
Tags (3)
1 Solution

Accepted Solutions
AmitHazra
Esri Contributor

Can you please change the default radio button to the units you've adjusted the decimal precision for. It seems in the screenshot you are still using two decimals:

AmitHazra_0-1615489435427.png

-amit@esri

View solution in original post

8 Replies
RyanKoschatzky
Regular Contributor

Talking with @Amit with esri last night. Identify and that link is the poor man's version of the tool without R&H in Pro. Please mention if that doesn't work as that is our planned workaround. 

Hope that helps. 

0 Kudos
CliveReece
Esri Contributor

Brian,

As you noted, the Explore/Identify tool does display the M-value at the point clicked.  The way to get more decimal places in the M display is: 

First:  Project tab > Options > Select "Units" > expand the "Distance Units" section

Then:  See which unit is the Default.  Double-click on the Format for this unit > Numeric Format opens up > Adjust the Decimal places to a higher number

Finish:  Hit OK, OK, (arrow back to project)

Now you should see more decimals of precision for the M value when you use the Explore/Identify tool. 

Regards,

RyanKoschatzky
Regular Contributor

Forgot to credit Clive with that help as well. 

0 Kudos
bbieb
by
Occasional Contributor

I tried that before posting.  Tried it again and it doesn't change.  I modified both the 'miles' and the 'meters' since it is UTM Zone 14N and the measures are in miles.  I closed and re-opened the Project, still no luck. 

Am I missing something simple?

I am at Pro 2.7.1.

measure-pro-units.png

 

measure-pro-identify.png

brian
0 Kudos
AmitHazra
Esri Contributor

Can you please change the default radio button to the units you've adjusted the decimal precision for. It seems in the screenshot you are still using two decimals:

AmitHazra_0-1615489435427.png

-amit@esri

View solution in original post

bbieb
by
Occasional Contributor

We have a winner.  I get the joke now, I was thinking measures was in miles so that is where I adjusted the decimals.  Thanks @AmitHazra , @CliveReece and @RyanKoschatzky 

brian
RyanKoschatzky
Regular Contributor

@AmitHazra we had the same issue as Brian and your response fixed it. Thanks.

0 Kudos
CliveReece
Esri Contributor

Brian, look for which is the Default unit.  In your first screen shot, I think I am seeing Foot as the default unit in your project. 

Adjust that unit's decimal precision up. 

This was counterintuitive to me when I first encountered it, because like you, the dataset I was working with was also in meters, the measures were calibrated to miles, but the default display unit was Foot.  

P.S. I tested switching my default units to Miles, and the Explore/Identify started using that decimal precision for distances.