Trouble running R Integration.pyt toolbox w/ ArcGIS pro

944
16
Jump to solution
10-11-2017 12:50 PM
PhilippeLachapelle
New Contributor

Hi,

I'm trying to setup my work environment to start using ArcGIS pro with R but I'm having trouble running the R Integration python's script.

I have downloaded the Bridge, I have R studio 3.3.2 and ArcGIS Pro (12.0.0.8933 - free demo trial).

When I add the R Integration.pyt toolbox I don't see any of the 4 scripts showing up?

I have attached 2 images resuming the situation.

Any idea what I can do to fox this?

Regards

Philippe

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
MarjeanPobuda
Occasional Contributor

Thomas,

Thank you for all of your time in trying out these different options. I am sorry this is proving to be so complicated. Based on your comment though, it sounds like if you make a minor tweak, you should be able to get the bridge installed. 

1) I have a feeling this might not work, but if you have time, try following the instructions for an offline installation of the bridge. 

Offline Installation

  • From a machine that does have internet access:
  • Copy both zip files onto the machine that you're targeting offline installation. Extract the r-bridge-install zip. Place the arcgisbinding_1.0.0.128.zip into the same directory as the "R Integration" Python toolbox.
  • Run the installation procedure as you previously did in 1) 

That error message saying, "Unable to access online package, and no local copy of package found." should be gone but, my guess is that there will still be some type of folder issue error since something about that structure on your machine is different than expected. I am mostly just curious what it will say ... 

2) So it appears that R was able to install the package ... but not in the expected location of C:\Users\<insert-your-user-name-here>\Documents\R\win-library\3.3. So where did it install? A couple of things:

   - First, copy the arcgisbinding folder that is located inside of your zipped folder and manually paste it in your ...\Documents\R\win-library\3.3 folder. 

   - In R, run the following:

      library(arcgisbinding)

      arc.check_product()

You should have succeeded in, hopefully, beating the system and having both R and ArcGIS now recognize the arcgisbinding package and therefore, have the bridge installed. 

*Fingers crossed,

Marjean

View solution in original post

0 Kudos
16 Replies
DanPatterson_Retired
MVP Esteemed Contributor

in the package manager for Pro (via the project window), did you install 'r' through there? since Pro is pretty strict about where it accesses packages.  Perhaps you can reference the document that describes the procedure for setting up Pro and R and the R integration script

0 Kudos
MarjeanPobuda
Occasional Contributor

Hi Philippe,

I am sorry that you are encountering issues. I have tried to reproduce what you are seeing using the trial version of Pro but currently, I am unable to. When you get a chance, could you check something for me to help us troubleshoot? Starting in ArcGIS Pro 2.0, we have an improved installer for the bridge. This video contains the installation instructions for the bridge when you are working with Pro 2.0+. Could you try installing the bridge this way and send me the messages that appear in the bridge installer? Hopefully this will give us some hints as to what might be going on. 

Thank you and let me know what you find out! 

-Marjean

ShaunWalbridge
Esri Regular Contributor

Following up on what Marjean wrote, we've released a new version of the bridge which should address this regression for Pro users. As Marjean says, it's even easier in Pro to use the built-in installer, but if you'd like to use the toolbox, try downloading it again and the toolbox should now open.


Cheers,

Shaun

ThomasTisserant
New Contributor

Hi Marjean,

Following the instructions in the video, I tried using the installer under options>Geoprocessing>R-ArcGIS Support and got a pop up error with the following message

C:\Program" is not recognized as an internal or external command, operable program or batch file.

It is also visible in the attached screen shot.

R bridge built-in installer error

There is no "C:\Program" folder on my computer. Instead, I have "C:\Program Files" folder, under which ArcGIS Pro 2.1.0 is installed.

My R version is R-3.3.1.

Would you have a tip for that error?

Thanks,

Thomas

0 Kudos
MarjeanPobuda
Occasional Contributor

Hi Thomas,

I am sorry to hear you are running into issues. Based on your snapshot, it appears the installer has successfully recognized the location R 3.3.1 is installed at in C:\Program Files. When are you encountering that error message? What option did you select from the drop-down button to the right of the message that reads: "Please install the ArcGIS R integration package"? 

Just let me know! 

Thank you,

Marjean

0 Kudos
ThomasTisserant
New Contributor

arcgis r bridge installation error - steps

Thanks Marjean

1. I selected "Install package from the Internet"

2. I clicked "yes" to "New arcgisbinding version 1.0.0.128 is available. Would you like to install it?"

3. The error message popped up

I've captured the steps in the attached screenshot.

In step 2. if I click "no" to  "New arcgisbinding version 1.0.0.128 is available. Would you like to install it?" I return to the Options window. 

0 Kudos
MarjeanPobuda
Occasional Contributor

Thanks Thomas. 

I tried to reproduce your issue on a machine with Pro 2.1 and R 3.3.1 but I was unable to do so. My best guess right now is that there is some type of local setting on your machine that is confusing the installer. So let's try checking a couple of things:

1) Do you have an R folder located in your Documents? This folder should contain the win-library folder and is where the installer will initially look to install the arcgisbinding package to. 

2) Have you modified any of your environmental variables or path regarding R? This can be checked in File Explorer by right clicking on This PC and then selecting Advanced system settings, followed by Environment Variables... Under System variables have you defined any variables pertaining to R? Such as R_HOME? (Just a note: the image here is just an example, having R_HOME set can cause multiple problems since it is hard coding a location that should be fluid). 

 

3) What happens when you try to install the bridge from file? To test this, download the latest version of the bridge and save it to a location of your choice. There is no need to unzip this file. In the R-ArcGIS bridge installer, instead of selecting the option to download and install from the internet, select the option to install from file. Navigate to the location you saved the arcgisbinding_1.0.0.128.zip and select the zipped folder. 

Just let me know whenever you get a chance. 

Thank you for your help tracking down this issue.

-Marjean

0 Kudos
ThomasTisserant
New Contributor

1)

Do you have an R folder located in your Documents? This folder should contain the win-library folder and is where the installer will initially look to install the arcgisbinding package to.

Yes, I have two R folders:

My Document/R/win-library/3.3
My Document/R/win-library/3.1

2)

Have you modified any of your environmental variables or path regarding R?

No, I didn't find any variable that looks R-related, and don't have R_HOME.

By the way, I should have specified earlier that I'm under Windows 7.

trouble shooting ArcGIS R Bridge installation error - environment variables

3)

What happens when you try to install the bridge from file?

1. I downloaded arcgisbinding_1.0.0.128.zip 

2. In Options/Geoprocessing/R-ArcGIS Support I selected "Install from file"

3. I navigated to where I had saved the file, and selected the file

4. There was briefly (1second) a blue status bar showing installation until the same pop up error appeared ("'C:\Program' is not recognized as an internal or external command, operable program or batch file").

Here's more info on my machine and my R version

Machine

Windows 7 professional

Service pack 1

Intel (R) code (TM) i5-6300U CPU @ 2.40GHz

8Gb RAM

64-bit operating system

R

0 Kudos
MarjeanPobuda
Occasional Contributor

Hi Thomas,

I have to admit, I am a bit baffled. Without access to your machine, it gets tricky to pinpoint what is the problem as I am unable to reproduce the issue. 

We have two possible workarounds to see if we can get the bridge installed for you. 

1) Can you try to see if you can install the bridge using the Python installer? The process for installing this way is detailed in this installation video. This installation process will still work for later versions of Pro than 1.4.1, like Pro 2.1. 

2) Alternatively, you can manually install the bridge through R by following these steps:

   -  Close Pro

   -  Download the arcgisbinding_1.0.0.128.zip

   -  Open R 3.3.1 64-bit

   -  Click the Packages tab and select Install Package(s) from local files...

   -  Navigate to and select arcgisbinding_1.0.0.128.zip. You should see a message the packages has installed.

 

   -  Reopen Pro and navigate to the R-Bridge Support under the Project tab's Geoprocessing Options. When you select R version 3.3.1 from the drop-down, you should now see that the arcgisbinding package is installed. 

Let me know how it goes!

-Marjean

0 Kudos