"Failed to load notebook" when using custom environment

195
6
11-21-2022 03:38 AM
A_Schwab
New Contributor II

I've set up a cloned custom Python environment in ArcPro 3.0.2 to set up the r-arcgisbridge package.

Cloning the environment and installing the package work ok, but when opening a notebook, I get an error, "Failed to load notebook".

If I switch back to the default environment I can load a notebook ok.

Any advice on how to fix this?

 

 

6 Replies
DanPatterson
MVP Esteemed Contributor

This package was installed?

Install the Conda package r-arcgis-essentials


... sort of retired...
0 Kudos
A_Schwab
New Contributor II

Thanks Dan, I've tried installing `r-arcgis-essentials` but it throws an error:

Collecting package metadata (current_repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Solving environment: ...working... failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): ...working... done
Solving environment: ...working... failed with initial frozen solve. Retrying with flexible solve.
Building graph of deps: 0%| | 0/4 [00:00<?, ?it/s]
Examining @/win-64::__win==0=0: 0%| | 0/4 [00:00<?, ?it/s]
Examining python=3.9: 25%|##5 | 1/4 [00:00<?, ?it/s]
Examining @/win-64::__archspec==1=x86_64: 50%|##### | 2/4 [00:00<00:00, 12.28it/s]
Examining @/win-64::__archspec==1=x86_64: 75%|#######5 | 3/4 [00:00<00:00, 18.43it/s]
Examining r-arcgis-essentials=1.1: 75%|#######5 | 3/4 [00:00<00:00, 18.43it/s]

Determining conflicts: 0%| | 0/4 [00:00<?, ?it/s]
Examining conflict for python r-arcgis-essentials: 0%| | 0/4 [00:00<?, ?it/s]

Solving environment: ...working...
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed
UnsatisfiableError: The following specifications were found to be incompatible with each other:
Output in format: Requested package -> Available versions

 

0 Kudos
DanPatterson
MVP Esteemed Contributor

windows machine?

Files :: Anaconda.org

looks like there have only been 10 downloads in the last 7 months.

I'll see if there is a more appropriate place to move this thread.


... sort of retired...
0 Kudos
DanPatterson
MVP Esteemed Contributor

You might want to have a look over here too

R-ArcGIS/r-bridge-install: Install the R ArcGIS Tools (github.com)


... sort of retired...
0 Kudos
HeatherChamberlain
New Contributor

Did you find any resolution for this? I'm getting the same issue with installing geopandas and rasterio packages in a cloned environment. If I switch back to the default environment then Notebook loads fine. I've tried reinstalling ArcGIS Pro (3.0.0) and no change and I get the exact same issue if I do the same on another PC (with ArcGIS Pro 3.0.2). The later comments on this thread suggest this might be a new issue but no clear solution at this point https://community.esri.com/t5/arcgis-pro-questions/getting-an-error-quot-failed-to-load-notebook-quo...

0 Kudos
A_Schwab
New Contributor II

Sadly not - I tried a few different things but none of them worked so in the end I gave up.

0 Kudos