Pro Layout gives corrupt Python CIM .getDefinition(). Is there a way to fix the definition?

112
1
Jump to solution
2 weeks ago
Highlighted
New Contributor II

I have created a template in Pro and want to get original cim Definition so that I can automate setDefinition changes. 

 

lyt.getDefinition('V2') 

 

returns "RuntimeError: Point: Input value is not numeric".

Tags (4)
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
New Contributor II

After 15min of cascading deletion of element groups/elements and getDefinition() after every delete, I found a Group element (CIMGroupElement) that didn't have a rotationCenter x,y set where it was expecting a numeric value it was set to NaN. I have experienced some Pro bugs with heavy element group within groups and imagine this is something similar.

 

 

{
                "type" : "CIMGroupElement",
                "anchor" : "BottomLeftCorner",
                "name" : "Population Density",
                "visible" : true,
                "rotationCenter" : {
                  "x" : "NaN",
                  "y" : "NaN"
                }

 

 

View solution in original post

Tags (1)
Reply
0 Kudos
1 Reply
Highlighted
New Contributor II

After 15min of cascading deletion of element groups/elements and getDefinition() after every delete, I found a Group element (CIMGroupElement) that didn't have a rotationCenter x,y set where it was expecting a numeric value it was set to NaN. I have experienced some Pro bugs with heavy element group within groups and imagine this is something similar.

 

 

{
                "type" : "CIMGroupElement",
                "anchor" : "BottomLeftCorner",
                "name" : "Population Density",
                "visible" : true,
                "rotationCenter" : {
                  "x" : "NaN",
                  "y" : "NaN"
                }

 

 

View solution in original post

Tags (1)
Reply
0 Kudos