Select to view content in your preferred language

Popup not shown results through registered database

1784
8
08-10-2021 02:46 AM
TasadduqHussain
New Contributor III

In ArcGIS Enterprise 10.5,when i publish Map service through registered database (Oracle),identify (Pop-up) not shown on my map click.

Any solution will be highly appreciated

Thanks

0 Kudos
8 Replies
George_Thompson
Esri Frequent Contributor

Does the identify work correctly in ArcMap before publishing?

What version of Enterprise are you publishing to?

What is the version of Oracle?

--- George T.
0 Kudos
TasadduqHussain
New Contributor III

Using "Add Query Layer" i made select query from Oracle 11G (SDE tablespace),when i publish map without performing registered database,it's work fine but when registered database it's does not work.

Using 10.5 Enterprise.

Thanks

0 Kudos
George_Thompson
Esri Frequent Contributor

So the identify does not work once the DB is registered?

Does the account that is running Enterprise have permissions to the data also?

What is the geometry type being used in Oracle (ST or SDO)?

Sounds like a permissions issue between the Enterprise and the Oracle DB.

--- George T.
0 Kudos
TasadduqHussain
New Contributor III

Thanks George_Thompson for your guidance,

I am using SDE table space (automatically prepare 400MB with ArcSDE 10.0 setup ) in Oracle Database.

In Oracle Geometry type is ST.

With publishing MXD on ArcGIS Enterprise without registering DB,popup shown when i place MapServer in Flex Viewer 3.7.

But when publish MXD with DB registered,popup not shown in Flex Viewer 3.7 (when click on parcel it's just blink but not show any result).

Please guide me i stuck on this issue form last 3-4 days.

Thanks

 

 

0 Kudos
TasadduqHussain
New Contributor III

Any Solution will be highly appreciated.

0 Kudos
George_Thompson
Esri Frequent Contributor

I just realized that you are using the Flex Viewer with has been retired since June 2016: https://support.esri.com/en/Products/legacy-products/legacy-products/arcgis-api-for-flex/3-x#product...

That could be the issue. ArcGIS 10.5 came out in June 2017 after this was retired.

I would highly recommend moving towards a newer JS API that is supported.

--- George T.
0 Kudos
TasadduqHussain
New Contributor III

Thanks,

I place Identify MapServer in JS API,here facing same issue.

Below attach screenshot is tested using JS API.

0 Kudos
George_Thompson
Esri Frequent Contributor

Is the Geodatabase upgraded to the same version as Enterprise?

It may be best to work with a Support Analyst on this issue.

--- George T.
0 Kudos