WMS Service HTTP Status 400

7150
3
03-26-2014 10:26 PM
Labels (1)
Highlighted
New Contributor
Hello,

I used ArcGIS Server Manager (10.2) to create a WMS service for existent map (simple map from ESRI - World Topo Map). I enabled WMS checkbox in functionality of stated Map Server. I can view under Services/OGC-Services name and URL of WMS service (http://<my_hostname>:6080/arcgis/services/World_Topo_Map/MapServer/WMSServer). However, I got a server error by this link:

HTTP Status 400

type Status report
message
description The request sent by the client was syntactically incorrect.

Apache Tomcat/7.0.42

Can anyone who are successful with creating and using WMSServer shed some light on trouble shooting? I tried to create WMS services for different maps through ArcGIS Server Manager and I always got that error. This error is also for http://<my_hostname>:6080/arcgis/services - as if this way don't exist and there is not one WMS service.
Thanks in advance!

Kind regards,
Alexey
Reply
0 Kudos
3 Replies
Highlighted
Esri Contributor
Hello Alexey,
  The URL presented under OGCServices is in a format that is understood by applications displaying OGC services - like ArcMap or any ArcGIS Web API. If you are looking for a way to view the WMS capabilities in a browser then you will need append ?request=GetCapabilities&service=WMS to URL.

Example: http://<my_hostname>:6080/arcgis/services/World_Topo_Map/MapServer/WMSServer?request=GetCapabilities&service=WMS
Reply
0 Kudos
Highlighted
New Contributor

For the record, if you encounter this HTTP Status 400 error using ArcGIS 10.3.1 for Linux - it is a known bug. "BUG-000087955 - WMS services on ArcGIS for Server on Linux crash when performing a GetCapabilities request."

And it is solved by installing this patch: ArcGIS 10.3.1 for Server (Linux) WMS GetCapabilities Patch | Samples and Utilities

Reply
0 Kudos
Highlighted
Occasional Contributor

I am having the same issue adding a WMS service to not only ArcGIS Online but WebEOC.  It this URL format you are recommending what you use to add a WMS service to ArcGIS Online?

Reply
0 Kudos