How to solve one or more layers failed to draw?

11288
6
01-06-2017 11:01 AM
HannahDodd
New Contributor II

I need help solving this error. I had a feature class in a file database (so I could redesign the schema and test it before replacing the old schema). I used the same exact data and copied from the file database and pasted in the sde database. In my map, I replaced the data sources so they would match the new schema and I got the following error. Also my symbology changed for some of the features but not all of them. The reason I used the same map is so that the symbology would stay the same and it's the same data so I thought it would be fine. Does this have something to do with a definition query or labeling? If so, how do I find where to fix the query or labeling expressions?

One or more layers failed to draw:

FDO error: 0 [Failed to label layer Plot Dimension < 1:200 for class Default.]
Attribute column not found [42S22:[Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'Length'.] [GIS.DBO.CPlotDim][STATE_ID = 56975]
Attribute column not found [42S22:[Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Invalid column name 'PlotNumber'.] [GIS.DBO.CPlot][STATE_ID = 56975]

0 Kudos
6 Replies
ChrisDonohue__GISP
MVP Frequent Contributor

I don't know for sure if this is the case for your issue, but usually I find if I get "failure to draw" errors it is because I goofed on the Definition Query.  For example, typically this happens as the Definition Query was originally set for a File Geodatabase and the data I want to draw is now in SDE, so the fieldname of Shape.Area bombs out as it should be SDE's Shape.STArea() (or whatever is appropriate for the geometry type used in SDE, be it STGeometry, SDEBinary, etc).  So I'd check first your definition query for the specific field names to see that they match what is in the data in its current incarnation.

Chris Donohue, GISP

HannahDodd
New Contributor II

I tried to see if I have any definition queries that use the Length and PlotNumber but when I open properties on the features and go to definition query, there aren't any. Would they be defined anywhere else in the map?

0 Kudos
Mohammad_AtiqTotakhail
New Contributor

Thanks! this was useful it worked for me!! much appreciate it !!!

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor
0 Kudos
WesMiller
Regular Contributor III

Did you check if Length and PlotNumber fields exist in the data. Also check Properties Label tab Expression. There may be syntax error there.

HannahDodd
New Contributor II

I ended up just deleting the two layers of data and then adding them back into the map. I lost my symbology settings for those two layers but the errors went away. Thanks for all the help!